SDK Overview

Dynamsoft SourceAnywhere Hosted SDK

Dynamsoft SourceAnywhere Hosted provides a Software Development Kit (SDK) which enables software developers to integrate Dynamsoft SourceAnywhere Hosted functionality with their applications. Through Dynamsoft SourceAnywhere Hosted Software Development Kit's APIs, you can develop applications that provide the similar functionality as the client software of Dynamsoft SourceAnywhere Hosted.

Dynamsoft SourceAnywhere Hosted SDK includes the following two editions:

  • COM SDK
  • Java SDK


COM SDK

 ActiveX SDK COM SDK

Dynamsoft SourceAnywhere Hosted COM Software Development Kit (SDK) enables you to integrate Dynamsoft SourceAnywhere Hosted functionality with your Windows application that is written in a language that supports Microsoft's Component Object Model, such as Microsoft Visual C++ and Microsoft Visual Basic.

You can use Dynamsoft SourceAnywhere Hosted COM SDK to develop applications that provide the similar functionality as Dynamsoft SourceAnywhere Hosted Windows Client software.

This part of document is divided into the following sections:

  • Interfaces
  • Events
  • Enumerations
  • Error List


Interfaces

This section documents the interfaces exposed by Dynamsoft SourceAnywhere Hosted SDK. The core interface of Dynamsoft SourceAnywhere Hosted SDK is ISAWHAppObject interface. Other interfaces are used to retrieve information for ISAWHAppObject interface.

  • ISAWHAppObject Interface
  • ISAWHActionType Interface
  • ISAWHAddFile Interface
  • ISAWHAddFileSet Interface
  • ISAWHChangeSetIdInfo Interface
  • ISAWHChangeSetIdInfoSet Interface
  • ISAWHCheckinFile Interface
  • ISAWHCheckintFileSet Interface
  • ISAWHCheckoutFile Interface
  • ISAWHCheckoutFileSet Interface
  • ISAWHCheckoutFileStatus Interface
  • ISAWHCheckoutFileStatusSet Interface
  • ISAWHDeletedItemGeneralInfo Interface
  • ISAWHDeletedItemGeneralInfoSet Interface
  • ISAWHDeleteFileSet Interface
  • ISAWHDeleteItemFromLabel Interface
  • ISAWHDeleteItemFromLabelSet Interface
  • ISAWHDeleteProjectSet Interface
  • ISAWHDiffMergeParam Interface
  • ISAWHFileCommonInfo Interface
  • ISAWHFileCommonInfoSet Interface
  • ISAWHFileHistoryParam Interface
  • ISAWHFileListSet Interface
  • ISAWHFileStatusInSet Interface
  • ISAWHFileStatusOut Interface
  • ISAWHFileStatusOutSet Interface
  • ISAWHGlobalMessage Interface
  • ISAWHGlobalMessageSet Interface
  • ISAWHHistory Interface
  • ISAWHHistoryOrderBy Interface
  • ISAWHHistorySet Interface
  • ISAWHLabeledInfo Interface
  • ISAWHLabeledInfoSet Interface
  • ISAWHLabelFile Interface
  • ISAWHLabelFileSet Interface
  • ISAWHLatestFile Interface
  • ISAWHLatestFileSet Interface
  • ISAWHLatestProject Interface
  • ISAWHLatestProjectSet Interface
  • ISAWHLoginInfo Interface
  • ISAWHLoginInfoSet Interface
  • ISAWHMoveFileSet Interface
  • ISAWHOperationResult Interface
  • ISAWHOperationResultSend Interface
  • ISAWHOperationResultSendSet Interface
  • ISAWHOperationResultSet Interface
  • ISAWHProjectHistoryParam Interface
  • ISAWHProjectListSet Interface
  • ISAWHPurgeItem Interface
  • ISAWHPurgeItemSet Interface
  • ISAWHRecoverItem Interface
  • ISAWHRecoverItemSet Interface
  • ISAWHRepositoryInfo Interface
  • ISAWHRepositoryInfoSet Interface
  • ISAWHRight Interface
  • ISAWHShareFileSet Interface
  • ISAWHShareLink Interface
  • ISAWHShareLinkSet Interface
  • ISAWHUndoCheckoutFile Interface
  • ISAWHUndoCheckoutFileSet Interface
  • ISAWHUserSet Interface


AddFiles

ISAWHAppObject::AddFiles

Description

Adds multiple files to an existing project on the server.

Syntax

long AddFiles(
ISAWHAddFileSet* AddFileSet,
VARIANT_BOOL UseReadOnly,
BSTR Comment,
Enum_CompareFileBy CompareFileBy,
Enum_SetLocalFileTime SetLocalFileTime,
VARIANT_BOOL RemoveLocalCopy,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

AddFileSet
[in] Specifies the full names of files to be added.

UseReadOnly
[in] Specifies whether to use read-only flag on the unchecked-out local file copies after the Add operation.

Comment
[in] Specifies the comments for the Add operation.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

SetLocalFileTime
[in] Specifies how to set the date/time of the local file.

RemoveLocalCopy
[in] Specifies whether to delete the local file copies after the Add operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHAddFileSet Interface
  • ISAWHOperationResultSet Interface
  • Enum_CompareFileBy Enumeration
  • Enum_SetLocalFileTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub AddFiles_Click()

    Dim AddFileSet As New SAWHAddFileSet
    Dim Comment As String
    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim OperationResultSet As New SAWHOperationResultSet

    Dim AddFile As New SAWHAddFile
    AddFile.FileType = Enum_Autodetect
    AddFile.LocalFileName = "D:\LocalFile1.txt"
    AddFile.RemoteFileName = "$/FileName1.txt"
    AddFileSet.Add AddFile

    AddFile.FileType = Enum_Autodetect
    AddFile.LocalFileName = "D:\LocalFile2.txt"
    AddFile.RemoteFileName = "$/FileName2.txt"
    AddFileSet.Add AddFile

    Comment = "Add files"

    Dim ResultValue As Long
    ResultValue = sdkObject.AddFiles(AddFileSet, True, Comment, Enum_CompareFileByChecksum, Enum_SetLocalFileTimeCurrent, False, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox "Failed to add the file(s)."
    End If

End Sub


AddFolder

ISAWHAppObject::AddFolder

Description

Adds an entire local folder to the server.

Syntax

long AddFolder(
BSTR ParentProjectName,
BSTR LocalFolder,
VARIANT_BOOL Recursive,
BSTR Comment,
VARIANT_BOOL UseReadOnly,
Enum_FileType FileType,
Enum_CompareFileBy CompareFileBy,
Enum_SetLocalFileTime SetLocalFileTime,
VARIANT_BOOL RemoveLocalCopy,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

ParentProjectName
[in] Specifies the full name of project to which the folder will be added.

LocalFolder
[in] Specifies full name of the local folder to be added.

Recursive
[in] Specifies whether the folder will be added recursively.

Comment
[in] Specifies the comments for the Add operation.

UseReadOnly
[in] Specifies whether to use read-only flag on the unchecked-out local file copies after the Add operation.

FileType
[in] Specifies the types of files in the folder to be added.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

SetLocalFileTime
[in] Specifies how to set the date/time of the local file.

RemoveLocalCopy
[in] Specifies whether to delete the local file copies after the Add operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHOperationResultSet Interface
  • Enum_CompareFileBy Enumeration
  • Enum_SetLocalFileTime Enumeration
  • Enum_FileType Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub AddFolder_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim ParentProjectName As String
    Dim LocalFolder As String
    Dim Comment As String
    Dim OperationResultSet As New SAWHOperationResultSet

    ParentProjectName = "$/AddFolder"
    LocalFolder = "D:\LocalFolder"
    Comment = "Add folder"

    ResultValue = sdkObject.AddFolder(ParentProjectName, LocalFolder, False, Comment, True, Enum_Autodetect, Enum_CompareFileByChecksum, Enum_SetLocalFileTimeCurrent, False, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox ("Failed to add the local folder.")
    End If

End Sub


BranchFiles

ISAWHAppObject::BranchFiles

Description

Branches multiple files.

Syntax

long BranchFiles(
ISAWHBranchFileSet* BranchFileSet,
BSTR Comment,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
 ISAWHOperationResultSet* OperationResultSet
);

Parameters

BranchFileSet
[in] Specifies the full names of files to be branched.

Comment
[in] Specifies the comments for the Branch operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

ResultDescription
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHBranchFileSet Interface
  • ISAWHOperationResultSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub BranchFiles_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim BranchFileSet As New SAWHBranchFileSet
    Dim Comment As String
    Dim OperationResultSet As New SAWHOperationResultSet

    BranchFileSet.Add ("$/FileName.txt")
    Comment = "Branch files"

    Dim ResultValue As Long
    ResultValue = sdkObject.BranchFiles(BranchFileSet, Comment, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox "Failed to branch the file(s)."
    End If

End Sub


BranchProject

ISAWHAppObject::BranchProject

Description

Branches a project.

Syntax

long BranchProject(
BSTR ProjectName,
VARIANT_BOOL Recursive,
BSTR Comment,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the project to be branched.

Recursive
[in] Specifies whether the project will be branched recursively.

Comment
[in] Specifies the comments for the Branch operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub BranchProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim Comment As String
    Dim ProjectName As String

    dlgBranchProject.Text1.Text = "$/ProjectName"
    dlgBranchProject.Text2.Text = "Comment info"
    dlgBranchProject.Show 1, Me
    ProjectName = dlgBranchProject.Text1.Text
    Comment = dlgBranchProject.Text2.Text

    Dim ResultValue As Long
    ResultValue = sdkObject.BranchProject(ProjectName, False, Comment, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to branch the project."
    End If

End Sub


ChangeFileVersionInLabel

ISAWHAppObject::ChangeFileVersionInLabel

Description

Changes the file version of a label to another one.

Syntax

long ChangeFileVersionInLabel(
 long LabelIdLow,
long LabelIdHigh
 long FileHistoryIdLow,
 long FileHistoryIdHigh,
 long VersionNumberLow,
 long VersionNumberHigh,,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

LabelIdLow
[in] Specifies the low-order 32 bits of the label ID.

LabelIdHigh
[in] Specifies the high-order 32 bits of the label ID.

Note: LabelIdLow and LabelIdHigh form a single 64-bit label ID.

FileHistoryIdLow
[in] Specifies the low-order 32 bits of the file history's ID.

FileHistoryIdHigh
[in] Specifies the high-order 32 bits of the file history's ID.

Note: FileHistoryIdLow and FileHistoryIdHigh form a single 64-bit history ID.

VersionNumberLow
[in] Specifies the 32-bit version number of the file.

VersionNumberHigh
[in] Specifies the 64-bit version number of the file.

Note: VersionNumberLow and VersionNumberHigh form a single 64-bit version ID.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub ChangeFileVersionInLabel_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim FileName As String

    FileName = "$/FileName.txt"

    'At first Should get the file labeled info
    Dim LabeledInfoSet As New SAWHLabeledInfoSet
    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileLabeledInfo(FileName, LabeledInfoSet, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to get the file's label info."
        Exit Sub
    End If

    Dim LabeledInfo As New SAWHLabeledInfo
    LabeledInfoSet.Get 0, LabeledInfo

    ResultValue = sdkObject.ChangeFileVersionInLabel(LabeledInfo.LabelIdLow, LabeledInfo.LabelIdHigh, LabeledInfo.HistoryIdLow, LabeledInfo.HistoryIdHigh, LabeledInfo.VersionNumberLow, LabeledInfo.VersionNumberHigh, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to change the file version of the label."
    End If

End Sub


Checkin Files

ISAWHAppObject::CheckInFiles

Description

Checks in multiple files.

Syntax

long CheckInFiles(
ISAWHCheckinFileSet* CheckinFileSet,
VARIANT_BOOL KeepCheckout,
VARIANT_BOOL RemoveLocalCopy,
 Enum_CompareFileBy CompareFileBy,
Enum_EOL EOL,
VARIANT_BOOL UserReadOnly,
 VARIANT_BOOL ForceCheckin,
Enum_SetLocalFileTime SetLocalFileTime,
Enum_CheckinUnchangedFileHandling CheckinUnchangedFileHandling,
BSTR Comment,
ISAWHDiffMergeParam* MergeParam,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

CheckinFileSet
[in] Specifies the name set of the files to be checked in.

KeepCheckout
[in] Specifies whether to keep files checked out after the Check In operation.

RemoveLocalCopy
[in] Specifies whether to remove the file copies after the Check In operation.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

EOL
[in] Specifies which end-of-line terminator is to be used for files.

UseReadOnly
[in] Specifies whether to use read-only flag on the unchecked-out local files.

ForceCheckin
[in] Specifies whether to check in the unchanged file and updates its version number.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

CheckinUnchangedFileHandling
[in] Specifies how to handle the unchanged file, checking in or undoing checkout.

Comment
[in] Specifies the comments for the Check In operation.

MergeParam
[in] Specifies the parameters used for merge.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHCheckinFileSet Interface
  • ISAWHDiffMergeParam Interface
  • ISAWHOperationResultSet Interface
  • Enum_CompareFileBy Enumeration
  • Enum_EOL Enumeration
  • Enum_SetLocalFileTime Enumeration
  • Enum_CheckinUnchangedFileHandling Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub CheckinFiles_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim CheckinFileSet As New SAWHCheckinFileSet
    Dim CheckinFile As New SAWHCheckinFile
    Dim Comment As String
    Dim OperationResultSet As New SAWHOperationResultSet
    Dim MergeParam As New SAWHDiffMergeParam

    CheckinFile.FileToCheckin = "$/FileName.txt"
    CheckinFile.LocalFileName = "D:\LocalFileName.txt"
    CheckinFileSet.Add CheckinFile
    Comment = "Check in files"

    Dim ResultValue As Long
    ResultValue = sdkObject.CheckInFiles(CheckinFileSet, False, False, Enum_CompareFileByChecksum, Enum_EOLNative, False, False, Enum_SetLocalFileTimeCurrent, Enum_AskCheckinUnchangedFile, Comment, MergeParam, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox "Failed to check in the file(s)."
    End If

End Sub


CheckinProject

ISAWHAppObject::CheckInProject

Description

Checks in a project.

Syntax

long CheckInProject(
BSTR ProjectToCheckin,
BSTR LocalDirectory,
VARIANT_BOOL Recursive,
VARIANT_BOOL KeepCheckout,
VARIANT_BOOL RemoveLocalCopy,
VARIANT_BOOL ForceCheckin,
 Enum_CompareFileBy CompareFileBy,
Enum_EOL EOL,
VARIANT_BOOL UserReadOnly,
Enum_SetLocalFileTime SetLocalFileTime,
Enum_CheckinUnchangedFileHandling CheckinUnchangedFileHandling,
BSTR Comment,
ISAWHDiffMergeParam* MergeParam,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

ProjectToCheckin
[in] Specifies the full name of the project to be checked in.

LocalDirectory
[in] Specifies the local path from which the project is checked in.

Recursive
[in] Specifies whether the project will be checked in recursively.

KeepCheckout
[in] Specifies whether to keep files in the project checked out after the Check In operation.

RemoveLocalCopy
[in] Removes the local copies of files in the project after the Check In operation.

ForceCheckin
[in] Specifies whether to check in the unchanged file and updates its version number.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

EOL
[in] Specifies which end-of-line terminator is to be used for files.

UseReadOnly
[in] Specifies whether to use read-only flag on the unchecked-out local files.

SetLocalFileTime
[in] Specifies how to set the date/time of the local file.

CheckinUnchangedFileHandling
[in] Specifies how to handle the unchanged file, checking in or undoing checkout.

Comment
[in] Specifies the comments for the Check In operation.

MergeParam
[in] Specifies the parameters used for merge.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHDiffMergeParam Interface
  • ISAWHOperationResultSet Interface
  • Enum_CompareFileBy Enumeration
  • Enum_EOL Enumeration
  • Enum_SetLocalFileTime Enumeration
  • Enum_CheckinUnchangedFileHandling Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub CheckinProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim ProjectToCheckin As String
    Dim LocalDirectory As String
    Dim Comment As String
    Dim OperationResultSet As New SAWHOperationResultSet
    Dim MergeParam As New SAWHDiffMergeParam

    ProjectToCheckin = "$/ProjectName"
    LocalDirectory = "D:\ProjectToCheckin"
    Comment = "Check in project"

    Dim ResultValue As Long
    ResultValue = sdkObject.CheckInProject(ProjectToCheckin, LocalDirectory, False, False, False, False, Enum_CompareFileByChecksum, Enum_EOLNative, False, Enum_SetLocalFileTimeCurrent, Enum_AskCheckinUnchangedFile, Comment, MergeParam, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox "Failed to check in the project."
    End If

End Sub


CheckoutFiles

ISAWHAppObject::CheckoutFiles

Description

Checks out multiple files.

Syntax

long CheckoutFiles(
ISAWHCheckoutFileSet* CheckoutFileSet,
VARIANT_BOOL ExclusivelyCheckout,
BSTR Comment,
VARIANT_BOOL DoNotGetLocalCopy,
Enum_ModifiedFileHandling ModifiedFileHandling,
Enum_EOL EOL,
Enum_CompareFileBy CompareFileBy,
Enum_SetLocalFileTime SetLocalFileTime,
ISAWHDiffMergeParam* MergeParam,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

CheckoutFileSet
[in] Specifies the name set of files to be checked out.

ExclusivelyCheckout
[in] Specifies whether to request exclusive checkout of the files.

Comment
[in] Specifies the comments for the Check Out operation.

DoNotGetLocalCopy
[in] Specifies whether to copy the files to the local working folder when it is checked out.

ModifiedFileHandling
[in] Specifies how to handle the local file if a writable copy of the file exists in the local folder.

EOL
[in] Specifies which end-of-line terminator is to be used for files.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

MergeParam
[in] Specifies the parameters used for merge.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHCheckoutFileSet Interface
  • ISAWHDiffMergeParam Interface
  • ISAWHOperationResultSet Interface
  • Enum_ModifiedFileHandling Enumeration
  • Enum_EOL Enumeration
  • Enum_CompareFileBy Enumeration
  • Enum_SetLocalFileTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub CheckoutFiles_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim CheckoutFileSet As New SAWHCheckoutFileSet
    Dim CheckoutFile As New SAWHCheckoutFile
    Dim Comment As String
    Dim OperationResultSet As New SAWHOperationResultSet
    Dim MergeParam As New SAWHDiffMergeParam

    CheckoutFile.FileToCheckout = "$/FileName.txt"
    CheckoutFile.LocalFileName = "D:\LocalFileName.txt"
    Comment = "Check out files"
    CheckoutFileSet.Add CheckoutFile

    Dim ResultValue As Long
    ResultValue = sdkObject.CheckoutFiles(CheckoutFileSet, False, Comment, False, Enum_AskModifiedFile, Enum_EOLNative, Enum_CompareFileByChecksum, Enum_SetLocalFileTimeCurrent, MergeParam, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox "Failed to check out files."
    End If

End Sub


CheckoutProject

ISAWHAppObject::CheckoutProject

Description

Checks out a project.

Syntax

long CheckoutProject(
BSTR ProjectToCheckout,
BSTR LocalDirectory,
BSTR Comment,
VARIANT_BOOL ExclusivelyCheckout,
VARIANT_BOOL DoNotGetLocalCopy,
VARIANT_BOOL Recursive,
Enum_ModifiedFileHandling ModifiedFileHandling,
Enum_EOL EOL,
Enum_CompareFileBy CompareFileBy,
Enum_SetLocalFileTime SetLocalFileTime,
ISAWHDiffMergeParam* MergeParam,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

ProjectToCheckout
[in] Specifies the full name of the project to be checked out.

LocalDirectory
[in] Specifies the path of the local directory to which the project is checked out.

Comment
[in] Specifies the comments for the Check Out operation.

ExclusivelyCheckout
[in] Specifies whether to request exclusive checkout of the project.

DoNotGetLocalCopy
[in] Specifies whether to copy the project to the local working folder when it is checked out.

Recursive
[in] Specifies whether the folder is to be checked out recursively.

ModifiedFileHandling
[in] Specifies how to handle the local file if a writable copy of the file exists in the local folder..

EOL
[in] Specifies which end-of-line terminator is to be used for files.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

MergeParam
[in] Specifies the parameters used for merge.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHDiffMergeParam Interface
  • ISAWHOperationResultSet Interface
  • Enum_ModifiedFileHandling Enumeration
  • Enum_EOL Enumeration
  • Enum_CompareFileBy Enumeration
  • Enum_SetLocalFileTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub CheckoutProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim ProjectToCheckout As String
    Dim LocalDirectory As String
    Dim Comment As String
    Dim OperationResultSet As New SAWHOperationResultSet
    Dim MergeParam As New SAWHDiffMergeParam

    ProjectToCheckout = "$/ProjectName"
    LocalDirectory = "D:\ProjectToCheckout"
    Comment = "Check out project"

    Dim ResultValue As Long
    ResultValue = sdkObject.CheckoutProject(ProjectToCheckout, LocalDirectory, Comment, False, False, False, Enum_AskModifiedFile, Enum_EOLNative, Enum_CompareFileByChecksum, Enum_SetLocalFileTimeCurrent, MergeParam, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox "Failed to check out project."
    End If

End Sub


ConnectToServer

ISAWHAppObject::ConnectToServer

Description

Connects to Dynamsoft SourceAnywhere Hosted Server directly or through your cache server.

Syntax

long ConnectToServer(
long OrganizationID,
VARIANT_BOOL UseCacheServer,
VARIANT_BOOL UseSSL,
BSTR CacheServerAddress,
long CacheServerPort,
Enum_ProxyType ProxyType,
BSTR ProxyAddress,
long Proxyport,
BSTR ProxyUserName,
BSTR ProxyPassword,
Enum_EncryptType* EncryptType,
ISAWHGlobalMessageSet* GlobalMessageSet,
BSTR * PlanName,
VARIANT_BOOL *Cancelled,
BSTR* ResultDescription
);

Parameters

OrganizationID
[in] Specifies the organization ID that is part of your hosted account identity.

UseCacheServer
[in] Specifies whether to connect to hosted server through your cache server.

UseSSL
[in] Specifies whether to connect to SSL encrypted port.

CacheServerAddress
[in] Specifies the domain name or IP address of your cache server if it is used.

CacheServerPort
[in] Specifies the port of your cache server if it is used.

ProxyType
[in] Specifies the type of the proxy server.

ProxyAddress
[in] Specifies the IP or domain name of proxy server (if proxy is used).

Proxyport
[in] Specifies the port of proxy server (if proxy is used).

ProxyUserName
[in] Specifies the identification used to login the proxy server (if proxy is used and requires authentication).

ProxyPassword
[in] Specifies the password for the user to login the proxy sever (if proxy is used and requires authentication).

EncryptType
[out] Returns the encryption type.

GlobalMessageSet
[out] Returns the global messages received from Dynamsoft SourceAnywhere Hosted Server.

PlanName
[out] Returns the plan name of your hosted account.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHGlobalMessageSet Interface
  • Enum_EncryptType Enumeration
  • Enum_ProxyType Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub ConnectToServer_Click()

    Dim OrganizationID As Long
    ServerIP = 111
    Dim ServerPort As Long
    ServerPort = 7788

    Dim GlobalMessageSet As New ISAWHGlobalMessageSet
    Dim EncryptType As Enum_EncryptType
    Dim PlanName As String
    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim ResultValue As Long

    ResultValue = sdkObject.ConnectToServer(OrganizationID, False, False, "", 0, Enum_NOPROXY, "", 0, "", "", EncryptType, GlobalMessageSet, PlanName, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to connect to server.")
    End If

End Sub


CreateProject

ISAWHAppObject::CreateProject

Description

Creates a project.

Syntax

long CreateProject(
 BSTR ParentProjectName,
BSTR ProjectToCreate,
BSTR Comment,
VARIANT_BOOL* Cancelled,
 BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the parent project under which the new project will be created.

ProjectToCreate
[in] Specifies the name of the project to be created.

Comment
[in] Specifies the comments for the new project.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub CreateProject_Click()

    Dim ParentProjectName As String
    Dim ProjectToCreate As String
    Dim Comment As String
    Dim Cancelled As Boolean
    Dim ResultDescription As String

    ParentProjectName = "$/"
    ProjectToCreate = "SubProjectName"
    Comment = "CreateProject"

    ResultValue = sdkObject.CreateProject(ParentProjectName, ProjectToCreate, Comment, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to create the project on server.")
    End If

End Sub


DeleteItemsFromLabel

ISAWHAppObject::DeleteItemsFromLabel

Description

Deletes multiple items from a label.

Syntax

long DeleteItemsFromLabel(
 long LabelIdLow,
long LabelIdHigh,
ISAWHDeleteItemFromLabelSet* DeleteItemFromLabelSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

LabelIdLow
[in] Specifies the low-order 32 bits of the label ID.

LabelIdHigh
[in] Specifies the high-order 32 bits of the label ID.

Note: LabelIdLow and LabelIdHigh forms a single 64-bit label ID.

DeleteItemFromLabelSet
[in, out] Specifies the information set of items to be deleted from the label.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHDeleteItemFromLabelSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub DeleteItemFromLabel_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim DeleteItemFromLabelSet As New SAWHDeleteItemFromLabelSet

    Dim FileName As String

    FileName = "$/FileName.txt"

    'At first should get the file labeled info
    Dim LabeledInfoSet As New SAWHLabeledInfoSet
    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileLabeledInfo(FileName, LabeledInfoSet, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to get the file labeled info."
        Exit Sub
    End If
    Dim LabelInfo As New SAWHLabeledInfo
    LabeledInfoSet.Get 0, LabelInfo

    Dim DeleteItemFromLabel As New SAWHDeleteItemFromLabel
    DeleteItemFromLabel.HistoryIdLow = LabelInfo.HistoryIdLow
    DeleteItemFromLabel.HistoryIdHigh = LabelInfo.HistoryIdHigh
    DeleteItemFromLabelSet.Add DeleteItemFromLabel

    ResultValue = sdkObject.DeleteItemsFromLabel(LabelInfo.LabelIdLow, LabelInfo.LabelIdHigh, DeleteItemFromLabelSet, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox ("Failed to delete the item(s) from label.")
    End If

    Dim Count As Long
    Count = DeleteItemFromLabelSet.GetCount
    Dim Index As Long
    For Index = 0 To Count

        DeleteItemFromLabelSet.Get Index, DeleteItemFromLabel

        Dim Description As String
        Description = DeleteItemFromLabel.Description

        Dim IsSuccessful As Boolean
        IsSuccessful = DeleteItemFromLabel.Successful

        Dim HistoryIdLow As Long
        HistoryIdLow = DeleteItemFromLabel.HistoryIdLow

        Dim HistoryIdHigh As Long
        HistoryIdHigh = DeleteItemFromLabel.HistoryIdHigh

    Next

End Sub


DeleteFiles

ISAWHAppObject::DeleteFiles

Description

Deletes multiple files.

Syntax

long DeleteFiles(
ISAWHDeleteFileSet* DeleteFileSet,
 VARIANT_BOOL DestoryPermanently,
 VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

DeleteFileSet
[in] Specifies the full name set of the files to be deleted.

DestoryPermanently
[in] Specifies whether to destroy the files permanently.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHDeleteFileSet Interface
  • ISAWHOperationResultSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub DeleteFiles_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim OperationResultSet As New SAWHOperationResultSet
    Dim DeleteFileSet As New SAWHDeleteFileSet
    Dim FileName As String

    FileName = "$/FileName.txt"
    DeleteFileSet.Add FileName

    Dim ResultValue As Long
    ResultValue = sdkObject.DeleteFiles(DeleteFileSet, True, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox "Failed to delete the file(s)."
    End If

End Sub


DeleteProject

ISAWHAppObject::DeleteProject

Description

Deletes a project.

Syntax

long DeleteProject(
ISAWHDeleteProjectSet* DeleteProject,
 VARIANT_BOOL DestoryPermanently,
 VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

DeleteProject
[in] Specifies the full name set of the projects to be deleted.

DestoryPermanently
[in] Specifies whether to destroy the project permanently.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHDeleteProjectSet Interface
  • ISAWHOperationResultSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub DeleteProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim DeleteProjectSet As New SAWHDeleteProjectSet
    Dim OperationResultSet As New SAWHOperationResultSet

    DeleteProjectSet.Add "$/ProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.DeleteProject(DeleteProjectSet, True, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox "Failed to delete the project."
    End If

End Sub


GetAllRepositories

ISAWHAppObject::GetAllRepositories

Description

Retrieves information of all available repositories on the server.

Syntax

long GetAllRepositories(
ISAWHRepositoryInfoSet* RepositoryInfoSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

RepositoriesInfoSet
[out] Returns the information set of all available repositories in SourceAnywhere database.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHRepositoryInfoSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

'Login, GetAllRepositories
Private Sub Login_Click()

    Dim UserName As String
    Dim Password As String
    Dim RepositoryName As String
    Dim KeyFileSet As New SAWHKeyFileSet
    Dim MustChangePassword As Boolean
    Dim DaysOfExpiration As Long
    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim RepositoryInfoSet As New SAWHRepositoryInfoSet
    sdkObject.GetAllRepositories RepositoryInfoSet, Cancelled, ResultDescription

    dlgLogin.Combo1.Clear
    Dim Index As Long
    For Index = 0 To RepositoryInfoSet.GetCount() - 1
        Dim RepositoryInfo As New SAWHRepositoryInfo
        RepositoryInfoSet.Get Index, RepositoryInfo
        dlgLogin.Combo1.AddItem (RepositoryInfo.RepositoryName)
    Next
    If RepositoryInfoSet.GetCount() > 0 Then
        dlgLogin.Combo1.ListIndex = 0
    Else
        MsgBox "Database name not found."
        Exit Sub
    End If

    dlgLogin.Text1.Text = "admin"
    dlgLogin.Text2.Text = ""
    Dim Result As Long
    dlgLogin.Show 1, Me

    UserName = dlgLogin.Text1.Text
    Password = dlgLogin.Text2.Text
    RepositoryName = dlgLogin.Combo1.Text

    Dim ResultValue As Long
    ResultValue = sdkObject.Login(UserName, Password, DBName, RepositoryName, KeyFileSet, MustChangePassword, DaysOfExpiration, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to log on server.")
    End If

End Sub


GetAllUsers

ISAWHAppObject::GetAllUsers

Description

Retrieves all users in SAW database.

Syntax

long GetAllUsers(
ISAWHUserSet* UserSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

UserSet
[in] Specifies the name set of users in Dynamsoft SourceAnywhere Hosted.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHUserSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetAllUsers_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim UserSet As New SAWHUserSet

    Dim ResultValue As Long
    ResultValue = sdkObject.GetAllUsers(UserSet, Cancelled, ResultDescription)

    Dim Count As Long
    Count = UserSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1
        Dim UserName As String
        UserSet.Get Index, UserName
    Next

End Sub


GetChangeSetIdInfo

ISAWHAppObject::GetChangeSetIdInfo

Description

Retrieves information of all files or projects that are modified as part of the same change set as the selected item.

Syntax

long GetChangeSetIdInfo(
long ItemIdLow,
long ItemIdHigh,
long ChangeSetIdLow,
long ChangeSetIdHigh,
ISAWHChangeSetIdInfoSet* ChangeSetIdInfoSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ItemIdLow
[in] Specifies the 32-bit item ID.

ItemIdHigh
[in] Specifies the 64-bit item ID.

Note: ItemIdLow and ItemIdHigh form a single 64-bit item ID.

ChangeSetIdLow
[in] Specifies the low-order 32 bits of the change set ID.

ChangeSetIdHigh
[in] Specifies the high-order 32 bits of the change set ID.

Note: ChangeSetIdLow and ChangeSetIdHigh form a single 64-bit change set ID.

ChangeSetIdInfoSet
[out] Specifies the information of the items whose modifications are part of the change set.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHChangeSetIdInfoSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetChangeSetIdInfo_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim ChangeSetIdLow As Long
    Dim ChangeSetIdInfoSet As New SAWHChangeSetIdInfoSet
    Dim FileName As String

    FileName = "$/FileName.txt"

    'At first Should get the file history.
    Dim FileHistoryParam As New SAWHFileHistoryParam
    Dim IsPinned As Boolean
    Dim HistorySet As New SAWHHistorySet
    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileHistory(FileName, FileHistoryParam, IsPinned, HistorySet, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to get the file history."
        Exit Sub
    End If
    Dim History As New SAWHHistory
    HistorySet.Get 0, History
    ResultValue = sdkObject.GetChangeSetIdInfo(History.ItemIdLow, History.ItemIdHigh, History.ChangeSetIdLow, History.ChangeSetIdHigh, ChangeSetIdInfoSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to get the changeset id info.")
    End If

    Dim Count As Long
    Count = ChangeSetIdInfoSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1

        Dim ChangeSetIdInfo As New SAWHChangeSetIdInfo
        ChangeSetIdInfoSet.Get Index, ChangeSetIdInfo

        Dim ActionDateTime As Date
        ActionDateTime = ChangeSetIdInfo.ActionDateTime

        Dim ActionType As Enum_ActionType
        ActionType = ChangeSetIdInfo.ActionType

        Dim ActionDescription As String
        ActionDescription = ChangeSetIdInfo.ActionDescription

        Dim Comment As String
        Comment = ChangeSetIdInfo.Comment

        Dim ItemName As String
        ItemName = ChangeSetIdInfo.ItemName

        Dim ItemIdLow As Long
        ItemIdLow = ChangeSetIdInfo.ItemIdLow

        Dim ItemIdHigh As Long
        ItemIdHigh = ChangeSetIdInfo.ItemIdHigh

        Dim ItemVersionLow As Long
        ItemVersionLow = ChangeSetIdInfo.ItemVersionLow

        Dim ItemVersionHigh As Long
        ItemVersionHigh = ChangeSetIdInfo.ItemVersionHigh

        Dim LabelName As String
        LabelName = ChangeSetIdInfo.LabelName

        Dim UserName As String
        UserName = ChangeSetIdInfo.UserName

    Next

End Sub


GetFileCheckoutStatus

ISAWHAppObject::GetFileCheckoutStatus

Description

Retrieves the checkout status information of a file.

Syntax

long GetFileCheckoutStatus(
BSTR FileName,
ISAWHCheckoutFileStatusSet* CheckoutFileStatusSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileName
[in] Specifies the full name of the file.

CheckoutFileStatusSet
[out] Returns the checkout status information of the file.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHCheckoutFileStatusSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFileCheckoutStatus_Click()
    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim CheckoutFileStatusSet As New SAWHCheckoutFileStatusSet

    Dim FileName As String
    FileName = "$/FileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileCheckoutStatus(FileName, CheckoutFileStatusSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the file checked out status."
        Exit Sub
    End If

    Dim Count As Long
    Count = CheckoutFileStatusSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1
        Dim CheckoutFileStatus As New SAWHCheckoutFileStatus
        CheckoutFileStatusSet.Get Index, CheckoutFileStatus
        Dim DateTime As Date
        DateTime = CheckoutFileStatus.CheckoutDateTime
        Dim UserName As String
        UserName = CheckoutFileStatus.CheckoutUserName
        Dim Comment As String
        Comment = CheckoutFileStatus.Comment
        Dim VersionNumberLow As Long
        VersionNumberLow = CheckoutFileStatus.VersionNumberLow
        Dim VersionNumberHigh As Long
        VersionNumberHigh = CheckoutFileStatus.VersionNumberHigh
    Next

End Sub


GetFileGeneralInfo

ISAWHAppObject::GetFileGeneralInfo

Description

Gets the general information of a file.

Syntax

long GetFileGeneralInfo(
BSTR FileName,
 VARIANT_BOOL* IsMergeable,
long* RemoteVersionLow,
long* RemoteVersionHigh,
DATE* LastModified,
long* RemoteSizeLow,
long* RemoteSizeHigh,
BSTR* Comment,
 VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileName
[in] Specifies the full name of the file.

IsMergeable
[out] Returns whether the file is mergeable.

RemoteVersionLow
[out] Returns the low-order 32 bits of the server file's latest version number.

RemoteVersionHigh
[out] Returns the high-order 32 bits of the server file's latest version number.

Note: RemoteVersionLow and RemoteVersionHigh form a single 64-bit version number.

LastModified
[out] Returns the last modified date/time of the file on the server.

RemoteSizeLow
[out] Returns the low-order 32 bits of the server file's size.

RemoteSizeHigh
[out] Returns the high-order 32 bits of the server file's size.

Note: RemoteSizeLow and RemoteSizeHigh form a single 64-bit file size.

Comment
[out] Returns the comment of the file.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFileGeneralInfo_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim IsMergeable As Boolean
    Dim RemoteVersionLow As Long
    Dim RemoteVersionHigh As Long
    Dim LatestModified As Date
    Dim RemoteSizeLow As Long
    Dim RemoteSizeHigh As Long
    Dim Comment As String

    Dim FileName As String
    FileName = "$/FileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileGeneralInfo(FileName, IsMergeable, RemoteVersionLow, RemoteVersionHigh, LatestModified, RemoteSizeLow, RemoteSizeHigh, Comment, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the file general info."
    End If

End Sub


GetFileHistory

ISAWHAppObject::GetFileHistory

Description

Retrieves the history information of a file.

Syntax

long GetFileHistory(
BSTR FileName,
ISAWHFileHistoryParam* FileHistoryParam,
VARIANT_BOOL* IsPinned,
ISAWHHistorySet* HistorySet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileName
[in] Specifies the full name of the file.

FileHistoryparam
[in] Specifies the parameters to restrict the file history report.

IsPinned
[out] Returns whether the file is pinned.

HistorySet
[out] Returns the history information set of the file.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHFileHistoryParam Interface
  • ISAWHHistorySet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFileHistory_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim FileName As String
    Dim FileHistoryParam As New SAWHFileHistoryParam
    Dim IsPinned As Boolean
    Dim HistorySet As New SAWHHistorySet

    FileName = "$/FileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileHistory(FileName, FileHistoryParam, IsPinned, HistorySet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the file history."
    End If

    Dim Count As Long
    Count = HistorySet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1
        Dim History As New SAWHHistory
        HistorySet.Get Index, History

        Dim ActionDateTime As Date
        ActionDataTime = History.ActionDateTime

        Dim ActionDescription As String
        ActionDescription = History.ActionDescription

        Dim ActionType As Enum_ActionType
        ActionType = History.ActionType

        Dim CheckinDateTime As Date
        CheckinDateTime = History.CheckinDateTime

        Dim Comment As String
        Comment = History.Comment

        Dim ChangeSetIdLow As Long
        ChangeSetIdLow = History.ChangeSetIdHigh

        Dim ChangeSetIdHigh As Long
        ChangeSetIdHigh = History.ChangeSetIdHigh

        Dim FileSizeLow As Long
        FileSizeLow = History.FileSizeLow

        Dim FileSizeHigh As Long
        FileSizeHigh = History.FileSizeHigh

        Dim HistoryIdLow As Long
        HistoryIdLow = History.HistoryIdLow

        Dim HistoryIdHigh As Long
        HistoryIdHigh = History.HistoryIdHigh

        Dim IsMergeable As Boolean
        IsMergeable = History.IsMergable

        IsPinned = History.IsPinned

        Dim IsProject As Boolean
        IsProject = History.IsProject

        Dim ItemIdLow As Long
        ItemIdLow = History.ItemIdLow

        Dim ItemIdHigh As Long
        ItemIdHigh = History.ItemIdHigh

        Dim ItemName As String
        ItemName = History.ItemName

        Dim LabelName As String
        LabelName = History.LabelName

        Dim ModificationDateTime As Date
        ModificationDateTime = History.ModificationDateTime

        Dim UserName As String
        UserName = History.UserName

        Dim VersionNumberLow As Long
        VersionNumberLow = History.VersionNumberLow

        Dim VersionNumberHigh As Long
        VersionNumberHigh = History.VersionNumberHigh

    Next

End Sub


GetFileLabeledInfo

ISAWHAppObject::GetFileLabeledInfo

Description

Retrieves the information of the labels of a file .

Syntax

long GetFileLabeledInfo(
BSTR FileName,
ISAWHLabeledInfoSet* LabeledInfoSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the file you want to retrieve labeled information.

LabelInfoSet
[out] Returns the labeled information about the specified file.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHLabeledInfoSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFileLabeledInfo_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim FileName As String
    Dim LabeledInfoSet As New SAWHLabeledInfoSet

    FileName = "$/FileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileLabeledInfo(FileName, LabeledInfoSet, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to get the label info of the file."
    End If

End Sub


GetFileLatestVersionNumber

ISAWHAppObject::GetFileLatestVersionNumber

Description

Retrieves the latest version number of the file.

Syntax

long GetFileLatestVersionNumber(
BSTR FileName,
long* LatestVersionNumberLow,
long* LatestVersionNumberHigh,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileName
[in] Specifies the full name of the file.

LatestVersionNumberLow
[out] Returns the low-order 32 bits of the file's latest version number.

LatestVersionNumberHigh
[out] Returns the high-order 32 bits of the file's latest version number.

Note: LatestVersionNumberLow and LatestVersionNumberHigh form a single 64-bit version number.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFileLatestVersionNumber_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim LatestVersionNumberLow As Long
    Dim LatestVersionNumberHigh As Long
    Dim FileName As String

    FileName = "$/FileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileLatestVersionNumber(FileName, LatestVersionNumberLow, LatestVersionNumberHigh, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the latest version number of the file."
    End If

End Sub


GetFileListFromProject

ISAWHAppObject::GetFileListFromProject

Description

Retrieves the file list of a project.

Syntax

long GetFileListFromProject(
BSTR ProjectName,
ISAWHFileListSet* FileListSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the project.

FileListSet
[out] Returns the file list of the project.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHFileListSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFileListFromProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim FileListSet As New SAWHFileListSet
    Dim ProjectName As String

    ProjectName = "$/ProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileListFromProject(ProjectName, FileListSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the file list of the project."
        Exit Sub
    End If

    Dim Count As Long
    Count = FileListSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1
        Dim FileName As String
        FileListSet.Get Index, FileName
    Next

End Sub


GetFileRight

ISAWHAppObject::GetFileRight

Description

Retrieves the access rights that are granted for the current logged in user.

Syntax

long GetFileRight(
BSTR FileName,
ISAWHRight* Right,
VARIANT_BOOL* Cancelled,
BSTR ResultDescription,
);

Parameters

File Name
[in] Specifies the full name of the file.

Right
[out] Specifies the current user's access rights to the file.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHRight Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFileRight_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim Right As New SAWHRight
    Dim FileName As String

    FileName = "$/FileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileRight(FileName, Right, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the access rights of the file."
    End If

    Dim AddRight As Boolean
    AddRight = Right.HasRightOf(Enum_AddRight)

End Sub


GetFilesCommonInfo

ISAWHAppObject::GetFilesCommonInfo

Description

Retrieves the common information of files.

Syntax

long GetFilesCommonInfo(
ISAWHFileCommonInfoSet* FileCommonInfoSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileCommonInfoSet
[in, out] Specifies or returns general information about the files.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHFileCommonInfoSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFilesCommonInfo_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim FileCommonInfoSet As New SAWHFileCommonInfoSet
    Dim FileCommonInfo As New SAWHFileCommonInfo

    FileCommonInfo.FileName = "$/FileName.txt"
    FileCommonInfoSet.Add FileCommonInfo

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFilesCommonInfo(FileCommonInfoSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the file common info."
    End If

    Dim Count As Long
    Count = FileCommonInfoSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1

        FileCommonInfoSet.Get Index, FileCommonInfo

        Dim CheckinDateTime As Date
        CheckinDateTime = FileCommonInfo.CheckinDateTime

        Dim CheckoutUser As String
        CheckoutUser = FileCommonInfo.CheckoutUser

        Dim Description As String
        Description = FileCommonInfo.Description

        Dim FileLengthLow As Long
        FileLengthLow = FileCommonInfo.FileLengthLow

        Dim FileLengthHigh As Long
        FileLengthHigh = FileCommonInfo.FileLengthHigh

        Dim FileName As String
        FileName = FileCommonInfo.FileName

        Dim IsMergeable As Boolean
        IsMergeable = FileCommonInfo.IsMergable

        Dim ItemStatus As Enum_ItemStatus
        ItemStatus = FileCommonInfo.ItemStatus

        Dim ModificationDateTime As Date
        ModificationDateTime = FileCommonInfo.ModificationDateTime

        Dim IsSuccessful As Boolean
        IsSuccessful = FileCommonInfo.Successful

        Dim VersionNumberLow As Long
        VersionNumberLow = FileCommonInfo.VersionNumberLow

        Dim VersionNumberHigh As Long
        VersionNumberHigh = FileCommonInfo.VersionNumberHigh
    Next

End Sub


GetFileShareLinks

ISAWHAppObject::GetFileShareLinks

Description

Retrieves the full names of the projects sharing the file.

Syntax

long GetFileShareLinks(
BSTR FileName,
ISAWHShareLinkSet* ShareLinkSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileName
[in] Specifies the full name of the file.

ShareLinkSet
[out] Returns the share links of a file.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHShareLinkSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFileShareLinks_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim FileName As String
    Dim ShareLinkSet As New SAWHShareLinkSet

    FileName = "$/FileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFileShareLinks(FileName, ShareLinkSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the file share link(s)."
    End If

    Dim Count As Long
    Count = ShareLinkSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1
        Dim ShareLink As New SAWHShareLink
        ShareLinkSet.Get Index, ShareLink

        Dim LinkName As String
        LinkName = ShareLink.FileName

        Dim IsDeleted As Boolean
        IsDeleted = ShareLink.IsDeleted
    Next

End Sub


GetFilesStatus

ISAWHAppObject::GetFilesStatus

Description

Gets the status information of files.

Syntax

long GetFilesStatus(
ISAWHFileStatusInSet* FileStatusInSet,
ISAWHFileStatusOutSet* FileStatusOutSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileStatusInSet
[in] Specifies the full name set of the files.

FileStatusOutSet
[out] Returns the status set of the files.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHFileStatusInSet Interface
  • ISAWHFileStatusOutSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetFileStatus_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim FileStatusInSet As New SAWHFileStatusInSet
    Dim FileStatusOutSet As New SAWHFileStatusOutSet

    Dim FileName As String
    FileName = "$/FileName.txt"
    FileStatusInSet.Add FileName

    Dim ResultValue As Long
    ResultValue = sdkObject.GetFilesStatus(FileStatusInSet, FileStatusOutSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the file status."
        Exit Sub
    End If

    Dim Count As Long
    Count = FileStatusOutSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1
        Dim FileStatusOut As New SAWHFileStatusOut
        FileStatusOutSet.Get Index, FileStatusOut
        Dim FileStatus As Enum_ItemStatus
        FileStatus = FileStatusOut.FileStatus
        Dim IsCheckoutByMe As Boolean
        IsCheckoutByMe = FileStatusOut.IsCheckoutByMe
        Dim IsExists As Boolean
        IsExists = FileStatusOut.IsExists
    Next

End Sub


GetLatestFiles

ISAWHAppObject::GetLatestFiles

Description

Retrieves the latest version of files from the repository.

Syntax

l ong GetLatestFiles(
ISAWHLatestFileSet LatestFileSet,
VARIANT_BOOL MakeWritable,
Enum_ModifiedFileHandling ModifiedFileHandling,
Enum_EOL EOL,
Enum_CompareFileBy CompareFileBy,
Enum_SetLocalFileTime SetLocalFileTime,
ISAWHDiffMergeParam* MergeParam,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

LatestFileSet
[in] Specifies the name set of files to be retrieved from the server.

MakeWritable
[in] Specifies whether to make the local file writable after it is retrieved from the server.

ModifiedFileHandling
[in] Specifies how to handle the local file if a writable copy of the file exists in the local disk.

EOL
[in] Specifies which end-of-line terminator is to be used for files.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

MergeParam
[in] Specifies the parameters used for merge.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHLatestFileSet Interface
  • ISAWHDiffMergeParam Interface
  • ISAWHOperationResultSet Interface
  • Enum_ModifiedFileHandling Enumeration
  • Enum_EOL Enumeration
  • Enum_CompareFileBy Enumeration
  • Enum_SetLocalFileTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetLatestFiles_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim LatestFileSet As New SAWHLatestFileSet
    Dim LatestFile As New SAWHLatestFile
    Dim OperationResultSet As New SAWHOperationResultSet
    Dim MergeParam As New SAWHDiffMergeParam

    LatestFile.FileToGet = "$/FileName.txt"
    LatestFile.LocalFileName = "D:\LocalFileName.txt"
    LatestFileSet.Add LatestFile

    Dim ResultValue As Long
    ResultValue = sdkObject.GetLatestFiles(LatestFileSet, True, Enum_ReplaceModifiedFile, Enum_EOLNative, Enum_CompareFileByChecksum, Enum_SetLocalFileTimeCurrent, MergeParam, Cancelled, ResultDescription, OperationResultSet)
    If ResultValue <> 0 Then
        MsgBox "Failed to get the latest version of the files."
    End If

End Sub


GetLatestProject

ISAWHAppObject::GetLatestProject

Description

Retrieves the latest version of a project from the server.

Syntax

long GetLatestProject(
BSTR ProjectToGet,
BSTR LocalFolder,
VARIANT_BOOL Recursive,
VARIANT_BOOL MakeWritable,
Enum_ModifiedFileHandling ModifiedFileHandling,
Enum_EOL EOL,
Enum_CompareFileBy CompareFileBy,
Enum_SetLocalFileTime SetLocalFileTime,
ISAWHDiffMergeParam* MergeParam,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

ProjectToGet
[in] Specifies the full name of the project to be retrieved.

LocalFolder
[in] Specifies the local path to which the project is retrieved.

Recursive
[in] Specifies whether the folder is to be retrieved recursively.

MakeWritable
[in] Specifies whether to make the file writable after being retrieved from the server.

ModifiedFileHandling
[in] Specifies how to handle the local file if a writable copy of the file exists in the local disk.

EOL
[in] Specifies which end-of-line terminator is to be used for files.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

MergeParam
[in] Specifies the parameters used for merge.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHDiffMergeParam Interface
  • ISAWHOperationResultSet Interface
  • Enum_ModifiedFileHandling Enumeration
  • Enum_EOL Enumeration
  • Enum_CompareFileBy Enumeration
  • Enum_SetLocalFileTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetLatestProject()

    Dim ProjectToGet As String
    Dim LocalFolder As String
    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim MergeParam As New SAWHDiffMergeParam
    Dim OperationResultSet As New SAWHOperationResultSet
    Dim arrTempOperationResult As New SAWHOperationResultSet

    dlgLatestProjects.Text1.Text = "$/Project1"
    dlgLatestProjects.Text2.Text = "D:\Personal Folder\test"
    dlgLatestProjects.Show 1, Me
    ProjectToGet = dlgLatestProjects.Text1.Text
    LocalFolder = dlgLatestProjects.Text2.Text

    Dim ResultValue As Long
    ResultValue = sdkObject.GetLatestProject(ProjectToGet, LocalFolder, False, False, Enum_ReplaceModifiedFile, Enum_EOLNative, Enum_CompareFileByChecksum, Enum_SetLocalFileTimeCurrent, MergeParam, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox ("Failed to get the latest version of the project.")
    End If

End Sub


GetLatestProjects

ISAWHAppObject::GetLatestProjects

Description

Retrieves the latest versions of multiple projects from the server.

Syntax

long GetLatestProjects(
ISAWHLatestProjectSet* LatestProjectSet,
VARIANT_BOOL Recursive,
VARIANT_BOOL MakeWritable,
Enum_ModifiedFileHandling ModifiedFileHandling,
Enum_EOL EOL,
Enum_CompareFileBy CompareFileBy,
Enum_SetLocalFileTime SetLocalFileTime,
ISAWHDiffMergeParam* MergeParam,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

LatestProjectSet
[in] Specifies the name set of projects to be retrieved from the server.

Recursive
[in] Specifies whether the project is to be retrieved recursively.

MakeWritable
[in] Specifies whether to make the file writable after it is retrieved from the server.

ModifiedFileHandling
[in] Specifies how to handle the local file if a writable copy of the file exists in the local disk.

EOL
[in] Specifies which end-of-line terminator is to be used for files.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

MergeParam
[in] Specifies the parameters used for merge.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHLatestProjectSet Interface
  • ISAWHDiffMergeParam Interface
  • ISAWHOperationResultSet Interface
  • Enum_ModifiedFileHandling Enumeration
  • Enum_EOL Enumeration
  • Enum_CompareFileBy Enumeration
  • Enum_SetLocalFileTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetLatestProjects_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim MergeParam As New SAWHDiffMergeParam
    Dim OperationResult As New SAWHOperationResultSet
    Dim LatestProjectSet As New SAWHLatestProjectSet
    Dim LatestProject As New SAWHLatestProject
    Dim OperationResultSet As New SAWHOperationResultSet

    LatestProject.ProjectToGet = "$/ProjectName"
    LatestProject.LocalFolder = "D:\ProjectToGet"
    LatestProjectSet.Add LatestProject

    Dim ResultValue As Long
    ResultValue = sdkObject.GetLatestProjects(LatestProjectSet, False, False, Enum_ReplaceModifiedFile, Enum_EOLNative, Enum_CompareFileByChecksum, Enum_SetLocalFileTimeCurrent, MergeParam, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox ("Failed to get the latest versions of the projects.")
    End If

End Sub


GetAllRepositories

ISAWHAppObject::GetLoginInfos

Description

Retrieves the lasted 10 login records of your organization ID.

Syntax

long GetLoginInfos(
ISAWHLoginInfoSet* LoginInfoSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

LoginInfoSet
[out] Returns the lasted 10 login records of your organization ID;

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHLoginInfoSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetLoginInfos_Click()

    Dim LoginInfoSet As New SAWHLoginInfoSet
    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim ResultValue As Long
    ResultValue = sdkObject.GetLoginInfos(LoginInfoSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to get login info.")
    End If

End Sub


GetOldVersionFile

ISAWHAppObject::GetOldVersionFile

Description

Retrieves an old version of a file from the server.

Syntax

Long GetOldVersionFile(
BSTR FileName,
Long VersionNumberLow,
Long VersionNumberHigh,
BSTR LocalFileName,
VARIANT_BOOL MakeWritable,
Enum_ModifiedFileHandling ModifiedFileHandling,
Enum_EOL EOL,
Enum_CompareFileBy CompareFileBy,
Enum_SetLocalFileTime SetLocalFileTime,
ISAWHDiffMergeParam* MergeParam,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
);

Parameters

FileName
[in] Specifies the full name of the file to be retrieved.

VersionNumberLow
[in] Specifies the low-order 32 bits of the file version to be retrieved.

VersionNumberHigh
[in] Specifies the high-order 32 bits of the file version to be retrieved.

Note: VersionNumberLow and VersionNumberHigh form a single 64-bit version number.

LocalFileName
[in] Specifies the path name of the local file retrieved from the server.

MakeWritable
[in] Specifies whether to make the local file writable after being retrieved from the database.

ModifiedFileHandling
[in] Specifies how to handle the local file if a writable copy of the file exists in the local disk.

EOL
[in] Specifies which end-of-line terminator is to be used for files.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

MergeParam
[in] Specifies the parameters used for merge.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHDiffMergeParam Interface
  • Enum_ModifiedFileHandling Enumeration
  • Enum_EOL Enumeration
  • Enum_CompareFileBy Enumeration
  • Enum_SetLocalFileTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetOldVersionFile_Click()

    Dim VersionNumber As Double
    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim FileNameOnServer As String
    Dim VersionNumberLow As Long
    Dim LocalFileName As String
    Dim MergeParam As New SAWHDiffMergeParam

    FileNameOnServer = "$/FileName.txt"
    VersionNumberLow = 1
    LocalFileName = "D:\LocalFile.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetOldVersionFile(FileNameOnServer, VersionNumberLow, 0, LocalFileName, False, Enum_ReplaceModifiedFile, Enum_EOLNative, Enum_CompareFileByChecksum, Enum_SetLocalFileTimeCurrent, MergeParam, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox ("Faild to get an old version of the file.")
    End If

End Sub


GetOperationResultSend

ISAWHAppObject::GetOperationResultSend

Description

Sends the information of operation results to the client.

Syntax

long GetOperationResultSend(
 ISAWHOperationResultSend* OperationResultSend
);

Parameters

OperationResultSend
[out] Returns a piece of operation result information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHOperationResultSend Interface
  • OnSendStatusMessage Event


GetPercentDone

ISAWHAppObject::GetPercentDone

Description

Retrieves how much percent of the operation has been done.

Syntax

long GetPercentDone()

Parameters

No parameter.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • OnPercentDone Event


GetProjectGeneralInfo

ISAWHAppObject::GetProjectGeneralInfo

Description

Retrieves the general information of a project.

Syntax

long GetProjectGeneralInfo(
BSTR ProjectName,
 VARIANT_BOOL* Is Deleted,
 long* SubProjectNotDeleted,
 long* SubProjectsDeleted,
 long* FileNotDeleted,
 long* FilesDeleted,
long* RemoteVersionLow,
long* RemoteVersionHigh,
DATE* RemoteDateTime,
BSTR* CreationComment,
ISAWHDeletedItemGeneralInfoSet* DeletedItemGeneralInfoSet,
 VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the project.

IsDeleted
[out] Returns whether the project is deleted.

SubProjectsNotDeleted
[out] Returns the number of undeleted subprojects within the project.

SubProjectsDeleted
[out] Returns the number of deleted subprojects in the project.

FilesNotDeleted
[out] Returns the number of undeleted files in the project.

FilesDeleted
[out] Returns the number of deleted files in the project.

RemoteVersionLow
[out] Returns the low-order 32 bits of the server project's latest version number.

RemoteVersionHigh
[out] Returns the high-order 32 bits of the server project's latest version number.

Note: RemoteVersionLow and RemoteVersionHigh form a single 64-bit version number.

RemoteDateTime
[out] Returns the date/time of the latest project version on the server.

CreationComment
[out] Returns the comment of the project.

DeletedItemGeneralInfoSet
 [out] Returns the general information about the deleted items in the project.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHDeletedItemGeneralInfoSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetProjectGeneralInfo_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim ProjectName As String
    Dim IsDeleted As Boolean
    Dim SubProjectNotDeleted As Long
    Dim SubProjectsDeleted As Long
    Dim FileNotDeleted As Long
    Dim FilesDeleted As Long
    Dim RemoteVersionLow As Long
    Dim RemoteVersionHigh As Long
    Dim RemoteDateTime As Date
    Dim CreationComment As String
    Dim DeletedItemGeneralInfoSet As New SAWHDeletedItemGeneralInfoSet

    ProjectName = "$/ProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetProjectGeneralInfo(ProjectName, IsDeleted, SubProjectNotDeleted, SubProjectsDeleted, FileNotDeleted, FilesDeleted, RemoteVersionLow, RemoteVersionHigh, RemoteDateTime, CreationComment, DeletedItemGeneralInfoSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to get the project general info.")
    End If

    Dim Count As Long
    Count = DeletedItemGeneralInfoSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1

        Dim DeletedItemGeneralInfo As New SAWHDeletedItemGeneralInfo
        DeletedItemGeneralInfoSet.Get Index, DeletedItemGeneralInfo

        Dim ItemName As String
        ItemName = DeletedItemGeneralInfo.ItemName

        Dim IsProject As Boolean
        IsProject = DeletedItemGeneralInfo.IsProject

        Dim ItemIdLow As Long
        ItemIdLow = DeletedItemGeneralInfo.ItemIdLow

        Dim ItemIdHigh As Long
        ItemIdHigh = DeletedItemGeneralInfo.ItemIdHigh

    Next

End Sub


GetProjectHistory

ISAWHAppObject::GetProjectHistory

Description

Retrieves the history information of a project.

Syntax

long GetProjectHistory(
BSTR ProjectName,
ISAWHProjectHistoryParam* ProjectHistoryParam,
ISAWHHistorySet* HistorySet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the project.

ProjectHistoryparam
[in] Specifies the parameters to restrict the project history report.

HistorySet
[out] Returns the history information set of the project.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHProjectHistoryParam Interface
  • ISAWHHistorySet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetProjectHistory_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim ProjectHistoryParam As New SAWHProjectHistoryParam
    Dim HistorySet As New SAWHHistorySet
    Dim ProjectName As String

    ProjectName = "$/ProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetProjectHistory(ProjectName, ProjectHistoryParam, HistorySet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to get the project history.")
    End If

    Dim Count As Long
    Count = HistorySet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1
        Dim History As New SAWHHistory
        HistorySet.Get Index, History

        Dim ActionDateTime As Date
        ActionDataTime = History.ActionDateTime

        Dim ActionDescription As String
        ActionDescription = History.ActionDescription

        Dim ActionType As Enum_ActionType
        ActionType = History.ActionType

        Dim CheckinDateTime As Date
        CheckinDateTime = History.CheckinDateTime

        Dim Comment As String
        Comment = History.Comment

        Dim ChangeSetIdLow As Long
        ChangeSetIdLow = History.ChangeSetIdHigh

        Dim ChangeSetIdHigh As Long
        ChangeSetIdHigh = History.ChangeSetIdHigh

        Dim FileSizeLow As Long
        FileSizeLow = History.FileSizeLow

        Dim FileSizeHigh As Long
        FileSizeHigh = History.FileSizeHigh

        Dim HistoryIdLow As Long
        HistoryIdLow = History.HistoryIdLow

        Dim HistoryIdHigh As Long
        HistoryIdHigh = History.HistoryIdHigh

        Dim IsMergeable As Boolean
        IsMergeable = History.IsMergable

        IsPinned = History.IsPinned

        Dim IsProject As Boolean
        IsProject = History.IsProject

        Dim ItemIdLow As Long
        ItemIdLow = History.ItemIdLow

        Dim ItemIdHigh As Long
        ItemIdHigh = History.ItemIdHigh

        Dim ItemName As String
        ItemName = History.ItemName

        Dim LabelName As String
        LabelName = History.LabelName

        Dim ModificationDateTime As Date
        ModificationDateTime = History.ModificationDateTime

        Dim UserName As String
        UserName = History.UserName

        Dim VersionNumberLow As Long
        VersionNumberLow = History.VersionNumberLow

        Dim VersionNumberHigh As Long
        VersionNumberHigh = History.VersionNumberHigh

    Next

End Sub


GetProjectLabeledInfo

ISAWHAppObject::GetProjectLabeledInfo

Description

Retrieves the information of labels of a project .

Syntax

long GetProjectLabeledInfo(
BSTR ProjectName,
ISAWHLabeledInfoSet* LabeledInfoSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the project you want to get labeled information.

LabelInfoSet
[out] Returns the label information of the project.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHLabeledInfoSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetProjectLabeledInfo_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim ProjectName As String
    Dim LabeledInfoSet As New SAWHLabeledInfoSet

    ProjectName = "$/ProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetProjectLabeledInfo(ProjectName, LabeledInfoSet, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to get the label info of the project."
        Exit Sub
    End If

    Dim Count As Long
    Count = LabeledInfoSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1
        Dim LabeledInfo As New SAWHLabeledInfo
        LabeledInfoSet.Get Index, LabeledInfo

        Dim CheckinDateTime As Date
        CheckinDateTime = LabeledInfo.CheckinDateTime

        Dim Comment As String
        Comment = LabeledInfo.Comment

        Dim FileSizeLow As Long
        FileSizeLow = LabeledInfo.FileSizeLow

        Dim FileSizeHigh As Long
        FileSizeHigh = LabeledInfo.FileSizeHigh

        Dim HistoryIdLow As Long
        HistoryIdLow = LabeledInfo.HistoryIdLow

        Dim HistoryIdHigh As Long
        HistoryIdHigh = LabeledInfo.HistoryIdHigh

        Dim IsPinned As Boolean
        IsPinned = LabeledInfo.IsPined

        Dim IsProject As Boolean
        IsProject = LabeledInfo.IsProject

        Dim ItemIdLow As Long
        ItemIdLow = LabeledInfo.ItemIdLow

        Dim ItemIdHigh As Long
        ItemIdHigh = LabeledInfo.ItemIdHigh

        Dim ItemName As String
        ItemName = LabeledInfo.ItemName

        Dim ItemAt As String
        ItemAt = LabeledInfo.LabelAt

        Dim LabelDateTime As Date
        LabelDateTime = LabeledInfo.LabelDateTime

        Dim LabelIdLow As Long
        LabelIdLow = LabeledInfo.LabelIdLow

        Dim LabelIdHigh As Long
        LabelIdHigh = LabeledInfo.LabelIdHigh

        Dim LabelName As String
        LabelName = LabeledInfo.LabelName

        Dim LabelRoot As Boolean
        LabelRoot = LabeledInfo.LabelRoot

        Dim IsMergeable As Boolean
        IsMergeable = LabeledInfo.Mergable

        Dim UserName As String
        UserName = LabeledInfo.UserName

        Dim ModificationDateTime As Date
        ModificationDateTime = LabeledInfo.ModificationDateTime

        Dim VersionNumberLow As Long
        VersionNumberLow = LabeledInfo.VersionNumberLow

        Dim VersionNumberHigh As Long
        VersionNumberHigh = LabeledInfo.VersionNumberHigh

    Next

End Sub


GetProjectLatestVersionNumber

ISAWHAppObject::GetProjectLatestVersionNumber

Description

Retrieves the latest version number of a project.

Syntax

long GetProjectLatestVersionNumber(
BSTR ProjectName,
long* LatestVersionNumberLow,
long* LatestVersionNumberHigh,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the project.

LatestVersionNumberLow
[out] Returns the low-order 32 bits of the project's latest version number.

LatestVersionNumberHigh
[out] Returns the high-order 32 bits of the project's latest version number.

Note: LatestVersionNumberLow and LatestVersionNumberHigh form a single 64-bit version number.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetProjectLatestVersionNumber_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim LatestVersionNumberLow As Long
    Dim LatestVersionNumberHigh As Long
    Dim ProjectName As String

    ProjectName = "$/ProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetProjectLatestVersionNumber(ProjectName, LatestVersionNumberLow, LatestVersionNumberHigh, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the latest version number of the project."
    End If

End Sub


GetProjectListFromProject

ISAWHAppObject::GetProjectListFromProject

Description

Retrieves the subproject list of a project.

Syntax

long GetProjectListFromProject(
BSTR ProjectName,
ISAWHProjectListSet* ProjectListSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the project.

ProjectListSet
[out] Returns the subproject list of the project.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHProjectListSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetProjectListFromProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim ProjectListSet As New SAWHProjectListSet

    Dim ProjectName As String
    ProjectName = "$/ProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetProjectListFromProject(ProjectName, ProjectListSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the subproject list from the project."
    End If

    Dim Count As Long
    Count = ProjectListSet.GetCount
    Dim Index As Long
    For Index = 0 To Count - 1
        Dim SubProjectName As String
        ProjectListSet.Get Index, SubProjectName
    Next

End Sub


GetProjectRight

ISAWHAppObject::GetProjectRight

Description

Retrieves the access rights that the current logged in user has to the project.

Syntax

long GetProjectRight(
BSTR ProjectName,
ISAWHRight* Right,
VARIANT_BOOL* Cancelled,
BSTR ResultDescription,
);

Parameters

ProjectName
[in] Specifies the full name of the project.

Right
[out] Returns the current user's access rights to the project.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHRight Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub GetProjectRight_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim Right As New SAWHRight
    Dim ProjectName As String

    ProjectName = "$/ProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.GetProjectRight(ProjectName, Right, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to get the project rights."
        Exit Sub
    End If

    Dim AddRight As Boolean
    AddRight = Right.HasRightOf(Enum_AddRight)

End Sub


GetPromptCheckinOrUndoUnchangedFile

ISAWHAppObject::GetPromptCheckinOrUndoUnchangedFile

Description

Retrieves the prompt information when you attempt to check in an unchanged local file copy.

Syntax

long GetPromptCheckinOrUndoUnchangedFile( BSTR* Information);

Parameters

Information
[out] Returns the prompt information about whether to check in or undo check out the unchanged file.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • PromptCheckinUnchangeFile Event


GetPromptLeaveOrReplaceModifiedFile

ISAWHAppObject::GetPromptLeaveOrReplaceModifiedFile

Description

Retrieves the prompt information when you attempt to retrieve a file form server and a writable copy of the file already exits in the local disk.

Syntax

long GetPromptLeaveOrReplaceModifiedFile(
BSTR* Information,
VARIANT_BOOL* ThreeWayMerge,
);

Parameters

Information
[out] Returns the prompt information about whether to leave or replace the modified local file copy.

ThreeWayMerge
[out] Returns the prompt information about whether it is a three way merge.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • PromptLeaveOrReplaceWritableFile Event


GetPromptUndoCheckoutChangedFile

ISAWHAppObject::GetPromptUndoCheckoutChangedFile

Description

Retrieves the prompt information when you attempt to undo check out a changed file.

Syntax

long GetPromptUndoCheckoutChangedFile( BSTR* Information);

Parameters

Information
[out] Returns the prompt information about whether to undo check out the changed file.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • PromptUndoCheckoutChangedFile Event


IsFileSameAsOnServer

ISAWHAppObject::IsFileSameAsOnServer

Description

Compares a local file with any version of a file on the server.

Syntax

long IsFileSameAsOnServer(
BSTR LocalFileName,
BSTR RemoteFileName,
long VersionNumberLow,
long VersionNumberHigh,
Enum_CompareFileBy CompareFileBy,
 Enum_SetLocalFileTime SetLocalFileTime,
VARIANT_BOOL* IsFileSame,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

LocalFileName
[in] Specifies the path name of the local file.

RemoteFileName
[in] Specifies the full name of the server file.

VersionNumberLow
[in] Specifies the low-order 32 bits of the file version to be compared.

VersionNumberHigh
[in] Specifies the high-order 32 bits of the file version to be compared.

Note: VersionNumberLow and VersionNumberHigh form a single 64-bit version number.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

IsFileSame
[out] Returns whether the two files are identical.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • Enum_CompareFileBy Enumeration
  • Enum_SetLocalFileTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub IsFileSameAsOnServer_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim LocalFileName As String
    Dim RemoteFileName As String
    Dim IsFileSame As Boolean

    RemoteFileName = "$/FileName.txt"
    LocalFileName = "D:\FileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.IsFileSameAsOnServer(LocalFileName, RemoteFileName, 1, 0, Enum_EOLNative, Enum_CompareFileByChecksum, Enum_SetLocalFileTimeCurrent, IsFileSame, Cancelled, ResultDescription)

End Sub


IsProjectExistsOnServer

ISAWHAppObject::IsProjectExistsOnServer

Description

Retrieves whether a project exists on the server.

Syntax

long IsProjectExistsOnServer(
BSTR ProjectName,
 VARIANT_BOOL* IsExistsOnServer,
 VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the project.

IsExisting
[out] Returns whether the project exists on the server.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub IsProjectExistsOnServer_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim IsExistOnServer As Boolean
    Dim ProjectName As String

    ProjectName = "$/ProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.IsProjectExistsOnServer(ProjectName, IsExistOnServer, Cancelled, ResultDescription)

End Sub


LabelFiles

ISAWHAppObject::LabelFiles

Description

Labels multiple files.

Syntax

long LabelFiles(
 ISAWHLabelFileSet* LabelFileSet,
BSTR LabelName,
BSTR Comment,
 VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

LabelFileSet
[in] Specifies the name set of the files to be labeled.

LabelName
[in] Specifies the name of the label.

Comment
[in] Specifies the comments for the Label operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHLabelFileSet Interface
  • ISAWHOperationResultSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub LabelFiles_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim LabelFileSet As New SAWHLabelFileSet
    Dim LabelFile As New SAWHLabelFile
    Dim Comment As String
    Dim LabelName As String
    Dim OperationResultSet As New SAWHOperationResultSet

    LabelFile.LabelFileName = "$/FileName.txt"
    LabelFile.VersionNumberHigh = 0
    LabelFile.VersionNumberLow = 1
    LabelFileSet.Add LabelFile
    LabelName = "NewLabelName"
    Comment = "Label files"

    Dim ResultValue As Long
    ResultValue = sdkObject.LabelFiles(LabelFileSet, LabelName, Comment, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox ("Failed to label the file(s).")
    End If

End Sub


LabelProject

ISAWHAppObject::LabelProject

Description

Labels a project.

Syntax

long LabelProject(
 BSTR ProjectName,
 long VersionNumberLow,
 long VersionNumberHigh,
BSTR LabelName,
BSTR Comment,
 VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
);

Parameters

ProjectName
[in] Specifies the full name of the project to be labeled.

VersionNumberLow
[in] Specifies the low-order 32 bits of the file version to be labeled.

VersionNumberHigh
[in] Specifies the high-order 32 bits of the file version to be labeled.

Note: VersionNumberLow and VersionNumberHigh forms a single 64-bit version number.

LabelName
[in] Specifies the name of the label.

Comment
[in] Specifies the comments for the Label operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the result. If the operation succeeds, returns 'Completed'. If the operation fails, returns the error information.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub LabelProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim ProjectName As String
    Dim Comment As String
    Dim LabelName As String

    ProjectName = "$/ProjectName"
    LabelName = "NewLabelName"
    Comment = "Label project"

    Dim ResultValue As Long
    ResultValue = sdkObject.LabelProject(ProjectName, 1, 0, LabelName, Comment, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to label the project.")
    End If

End Sub


Login

ISAWHAppObject::Login

Description

Logs in a repository.

Syntax

Long Login(
BSTR UserName,
BSTR Password,
BSTR Repository,
VARIANT_BOOL* MustChangePassword,
Long* DaysOfExpiration,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

UserName
[in] Specifies the login username.

Password
[in] Specifies the login password.

Repository
[in] Specifies the name of the repository you want to log in.

MustChangePassword
[out] Returns whether the password must be changed at each login.

DaysOfExpiration
[out] Returns in how many days the password will expire.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

'Login, GetAllRepositories
Private Sub Login_Click()

    Dim UserName As String
    Dim Password As String
    Dim DBName As String
    Dim Repository As String
    Dim MustChangePassword As Boolean
    Dim DaysOfExpiration As Long
    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim RepositoryInfoSet As New SAWHRepositoryInfoSet
    sdkObject.GetAllRepositories RepositoryInfoSet, Cancelled, ResultDescription

    dlgLogin.Combo1.Clear
    Dim Index As Long
    For Index = 0 To RepositoryInfoSet.GetCount() - 1
        Dim RepositoryInfo As New SAWHRepositoryInfo
        RepositoryInfoSet.Get Index, RepositoryInfo
        dlgLogin.Combo1.AddItem (RepositoryInfo.RepositoryName)
    Next
    If RepositoryInfoSet.GetCount() > 0 Then
        dlgLogin.Combo1.ListIndex = 0
    Else
        MsgBox "Database name not found."
        Exit Sub
    End If

    dlgLogin.Text1.Text = "admin"
    dlgLogin.Text2.Text = ""
    Dim Result As Long
    dlgLogin.Show 1, Me

    UserName = dlgLogin.Text1.Text
    Password = dlgLogin.Text2.Text
    Repository = dlgLogin.Combo1.Text

    Dim ResultValue As Long
    ResultValue = sdkObject.Login(UserName, Password, Repository, MustChangePassword, DaysOfExpiration, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to log in the repository.")
    End If

End Sub


MoveFiles

ISAWHAppObject::MoveFiles

Description

Moves multiple files.

Syntax

l ong MoveFiles(
 ISAWHMoveFileSet* MoveFileSet,
BSTR TargetProjectName,
BSTR Comment,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
 ISAWHOperationResultSet* OperationResultSet
);

Parameters

MoveFileSet
[in] Specifies the full name set of the files to be moved.

TargetProjectName
[in] Specifies the full name of the target project to which the item will be moved.

Comment
[in] Specifies the comments for the Move operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHMoveFileSet Interface
  • ISAWHOperationResultSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub MoveFiles_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim MoveFileSet As New SAWHMoveFileSet
    Dim TargetProjectName As String
    Dim Comment As String
    Dim OperationResultSet As New SAWHOperationResultSet

    MoveFileSet.Add "$/FileName.txt"
    TargetProjectName = "$/ProjectName"
    Comment = "Move files"

    Dim ResultValue As Long
    ResultValue = sdkObject.MoveFiles(MoveFileSet, TargetProjectName, Comment, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox ("Failed to move the file(s).")
    End If

End Sub


MoveProject

ISAWHAppObject::MoveProject

Description

Moves a project.

Syntax

l ong MoveProject(
BSTR ProjectName,
BSTR TargetProjectName,
BSTR Comment,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the full name of the project to be moved.

TargetProjectName
[in] Specifies the full name of the target project to which the item will be moved.

Comment
[in] Specifies the comments for the Move operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub MoveProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim SrcProjectName As String
    Dim TargetProjectName As String
    Dim Comment As String

    SrcProjectName = "$/SrcProjectName"
    TargetProjectName = "$/TargetProjectName"
    Comment = "Move project"

    Dim ResultValue As Long
    ResultValue = sdkObject.MoveProject(SrcProjectName, TargetProjectName, Comment, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox ("Failed to move the project.")
    End If

End Sub


PinFile

ISAWHAppObject::PinFile

Description

Pins a file.

Syntax

long PinFile(
BSTR FileToPin,
long VersionNumberLow,
long VersionNumberHigh,
BSTR* FileToPinned,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileToPin
[in] Specifies the full name of the file to be pinned.

VersionNumberLow
[in] Specifies the low-order 32 bits of the file version to be pinned.

VersionNumberHigh
[in] Specifies the high-order 32 bits of the file version to be pinned.

Note: VersionNumberLow and VersionNumberHigh form a single 64-bit version number.

FileToPinned
[out] Returns the full name of the pinned file version.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub PinFile_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim VersionNumberLow As Long
    Dim FileToPin As String
    Dim FileToPinned As String

    FileToPin = "$/FileName.txt"
    VersionNumberLow = 1

    Dim ResultValue As Long
    ResultValue = sdkObject.PinFile(FileToPin, VersionNumberLow, 0, FileToPinned, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to pin the file."
    End If

End Sub


PurgeItems

ISAWHAppObject::PurgeItems

Description

Purges multiple deleted items.

Syntax

long PurgeItems(
ISAWHPurgeItemSet* PurgeItemSet,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

PurgeItemSet
[in, out] Specifies the full name set of the deleted items to be purged.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHPurgeItemSet Interface
  • ISAWHOperationResultSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub PurgeItems_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim PurgeItemSet As New SAWHPurgeItemSet
    Dim PurgeItem As New SAWHPurgeItem
    Dim OperationResultSet As New SAWHOperationResultSet

    PurgeItem.ItemName = "$/FileName.Txt"
    PurgeItemSet.Add PurgeItem
    PurgeItem.ItemName = "$/ProjectName"
    PurgeItemSet.Add PurgeItem

    Dim ResultValue As Long
    ResultValue = sdkObject.PurgeItems(PurgeItemSet, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox ("Failed to purge the deleted item(s).")
    End If

End Sub


RecoverItems

ISAWHAppObject::RecoverItems

Description

Recovers multiple deleted items.

Syntax

long RecoverItems(
ISAWHRecoverItemSet* RecoverItem,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

RecoverItemSet
[in, out] Specifies the full name set of the deleted items to be recovered.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHRecoverItemSet Interface
  • ISAWHOperationResultSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub RecoverItems_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim RecoverItemSet As New SAWHRecoverItemSet
    Dim RecoverItem As New SAWHRecoverItem
    Dim OperationResultSet As New SAWHOperationResultSet

    RecoverItem.ItemName = "$/FileName.txt"
    RecoverItemSet.Add RecoverItem
    RecoverItem.ItemName = "$/ProjectName"
    RecoverItemSet.Add RecoverItem

    Dim ResultValue As Long
    ResultValue = sdkObject.RecoverItems(RecoverItemSet, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox ("Failed to recover the deleted item(s).")
    End If

End Sub


RenameFile

ISAWHAppObject::RenameFile

Description

Renames a file.

Syntax

long RenameFile(
BSTR FileToRename,
BSTR NewFileName,
 VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileToRename
[in] Specifies the old full name of the file.

NewFileName
[in] Specifies the new name of the file.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub RenameFile_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim FileToRename As String
    Dim NewFileName As String

    FileToRename = "$/FileName.txt"
    NewFileName = "NewFileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.RenameFile(FileToRename, NewFileName, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to rename the file name."
    End If

End Sub


RenameLabel

ISAWHAppObject::RenameLabel

Description

Renames a label.

Syntax

long RenameLabel(
long LabelIdLow,
long LabelIdHigh,
BSTR NewLabelName,
 VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

LabelIdLow
[in] Specifies the low-order 32 bits of the label ID.

LabelIdHigh
[in] Specifies the high-order 32 bits of the label ID.

Note: LabelIdLow and LabelIdHigh form a single 64-bit label ID.

NewLabelName
[in] Specifies the new name of the Label.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub RenameLabel_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim FileName As String
    Dim NewLabelName As String

    FileName = "$/FileName.txt"
    NewLabelName = "NewLabelName"

    'At first should get the label info.
    Dim ResultValue As Long
    Dim LabeledInfoSet As New SAWHLabeledInfoSet
    ResultValue = sdkObject.GetFileLabeledInfo(FileName, LabeledInfoSet, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to get the file label info."
        Exit Sub
    End If

    Dim LabeledInfo As New SAWHLabeledInfo
    If LabeledInfoSet.Get(0, LabeledInfo) = False Then
        MsgBox "Failed to get the file label info."
        Exit Sub
    End If

    ResultValue = sdkObject.RenameLabel(LabeledInfo.LabelIdLow, LabeledInfo.LabelIdHigh, NewLabelName, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to rename the label name."
    End If

End Sub


RenameProject

ISAWHAppObject::RenameProject

Description

Renames a project on the server.

Syntax

long RenameProject(
BSTR ProjectName,
BSTR NewProjectName,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

ProjectName
[in] Specifies the old full name the project.

NewProjectName
[in] Specifies the new name of the project.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub RenameProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim ProjectName As String
    Dim NewProjectName As String

    ProjectName = "$/ProjectName"
    NewProjectName = "NewProjectName"

    Dim ResultValue As Long
    ResultValue = sdkObject.RenameProject(ProjectName, NewProjectName, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to rename the project."
    End If

End Sub


RequestCancel

ISAWHAppObject::RequestCancel

Description

Cancels a request.

Syntax

long RequestCancel(void);

Parameters

None.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub RequestCancel_Click()

    sdkObject.RequestCancel

End Sub


SetConnectionType

ISAWHAppObject::SetConnectionType

Description

Sets the connection type.

Syntax

long SetConnectionType(
 Enum_ConnectionType ConnectionType
);

Parameters

ConnectionType
[in] Specifies the connection type, such as Local Connection, Broad Band Connection and Narrow Band Connection.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • Enum_ConnectionType enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub SetConnectionType_Click()

    sdkObject.SetConnectionType Enum_BroadBandConnection

End Sub


SetFileType

ISAWHAppObject::SetFileType

Description

Sets the type of the file, mergeable or binary.

Syntax

long SetFileType(
BSTR FileName,
VARIANT_BOOL IsMergeable,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileName
[in] Specifies the full name of the file.

IsMergeable
[in] Specifies whether the file is mergeable.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub SetFileType_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim FileName As String

    FileName = "$/FileName.txt"

    Dim ResultValue As Long

    ResultValue = sdkObject.SetFileType(FileName, False, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to set the file type."
    End If

End Sub


SetPassword

ISAWHAppObject::SetPassword

Description

Changes the login password.

Syntax

long SetPassword(
BSTR NewPassword,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

NewPassword
[in] Specifies the new password.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub SetPassword_Click()

    Dim ResultValue As Long
    Dim Cancelled As Boolean
    Dim ResultDescription As String

    ResultValue = SdkObject.SetPassword("", Cancelled, ResultDescription)

    If ResultValue <> 0 Then
    MsgBox ("Calling 'SetPassword' function fails\r\n" + ResultDescription)
    End If

End Sub


SetPromptCheckinOrUndoUnchangedFile

ISAWHAppObject::SetPromptCheckinOrUndoUnchangedFile

Description

Sets the handling option when you attempt to check in an unchanged file.

Syntax

long SetPromptCheckinOrUndoUnchangedFile(
Enum_CheckinUnchangedFileHandling CheckinUnchangedFileHandling,
VARIANT_BOOL IsApplyToAllItems
);

Parameters

CheckinUnchangedFileHandling
[in] Specifies how to handle the file, checking in or undoing checkout.

Is ApplyToAllItems
[in] Specifies whether to apply the handling option to all items.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • Enum_CheckinUnchangedFileHandling Enumeration
  • PromptCheckinUnchangeFile Event


SetPromptLeaveOrReplaceModifiedFile

ISAWHAppObject::SetPromptLeaveOrReplaceModifiedFile

Description

Sets the handling option when you attempt to retrieve a file form server and a writable file copy already exits in the local disk.

Syntax

long SetPromptLeaveOrReplaceModifiedFile(
Enum_ModifiedFileHandling ModifiedFileHandling,
VARIANT_BOOL IsApplyToAllItems
);

Parameters

ModifiedFileHandling
[in] Specifies how to handle the local file copy, leaving the local file or replacing the local file with the version on server.

Is ApplyToAllItems
[in] Specifies whether to apply the handling option to all items

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • Enum_ModifiedFileHandling Enumeration
  • PromptLeaveOrReplaceWritableFile Event


SetPromptUndoCheckoutChangedFile

ISAWHAppObject::SetPromptUndoCheckoutChangedFile

Description

Sets the handling option when you attempt to undo check out a changed file.

Syntax

long SetPromptUndoCheckoutChangedFile(
Enum_UndoCheckOutChangedFileHandling UndoCheckOutChangedFileHandling,
VARIANT_BOOL IsApplyToAllItems
);

Parameters

UndoCheckOutChangedFileHandling
[in] Specifies how to handle the file, undoing checkout or not.

Is ApplyToAllItems
[in] Specifies whether to apply the handling option to all items.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • Enum_UndoCheckOutChangedFileHandling Enumeration
  • PromptUndoCheckoutChangedFile Event


SetTempDir

ISAWHAppObject::SetTempDir

Description

Sets the temporary directory of Dynamsoft SourceAnywhere Hosted. This method should be called before using connetToserver method.

Syntax

long SetTempDir(
BSTR TempDirectory
);

Parameters

TempDirectory
[in] Specifies the temporary directory of Dynamsoft SourceAnywhere Hosted.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.


ShareFiles

ISAWHAppObject::ShareFiles

Description

Shares files in a project to another project.

Syntax

long ShareFiles(
 ISAWHShareFileSet* ShareFileSet,
BSTR TargetProjectName,
VARIANT_BOOL BranchAfterShare,
BSTR Comment,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
 ISAWHOperationResultSet* OperationResultSet
);

Parameters

ShareFileSet
[in] Specifies the full name set of files to be shared.

TargetProjectName
[in] Specifies the full name of the target project to which the files will be shared.

BranchAfterShare
[in] Specifies whether to branch files in the project after the files is shared.

Comment
[in] Specifies the comments for the Share operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHShareFileSet Interface
  • ISAWHOperationResultSet Interface

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub ShareFiles_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim ShareFileSet As New SAWHShareFileSet
    Dim TargetProjectName As String
    Dim Comment As String
    Dim ShareResultSet As New SAWHShareResultSet
    Dim OperationResultSet As New SAWHOperationResultSet

    ShareFileSet.Add "$/ProjectName/FileName.txt"
    TargetProjectName = "$/TargetProjectName"
    Comment = "Share files"

    Dim ResultValue As Long
    ResultValue = sdkObject.ShareFiles(ShareFileSet, TargetProjectName, False, Comment, Cancelled, ResultDescription, OperationResultSet)

    If ResultValue <> 0 Then
        MsgBox "Failed to share the file(s)."
    End If

End Sub


ShareProject

ISAWHAppObject::ShareProject

Description

Shares a subproject to another project.

Syntax

long ShareProject(
BSTR SourceProjectName,
BSTR NewProjectName,
BSTR TargetProjectName,
VARIANT_BOOL Recursive,
VARIANT_BOOL BranchAfterShare,
BSTR Comment,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

SourceProjectName
[in] Specifies the full name of source project to be shared from.

NewProjectName
[in] Specifies the name of shared project in the target project.

TargetProjectName
[in] Specifies the full name of the target project to be shared to.

Recursive
[in] Specifies whether to share the project recursively.

BranchAfterShare
[in] Specifies whether to branch files in the project after the project is shared.

Comment
[in] Specifies the comments for the Share operation.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub ShareProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String

    Dim SourceProjectName As String
    Dim NewProjectName As String
    Dim TargetProjectName As String
    Dim ShareResultSet As New SAWHShareResultSet
    Dim OperationResultSet As New SAWHOperationResultSet
    Dim Comment As String

    SourceProjectName = "$/ProjectName"
    NewProjectName = "NewProjectName"
    TargetProjectName = "$/TargetProjectName"
    Comment = "Share project"

    Dim ResultValue As Long
    ResultValue = sdkObject.ShareProject(SourceProjectName, NewProjectName, TargetProjectName, False, False, Comment, ShareResultSet, Cancelled, ResultDescription)

    If ResultValue <> 0 Then
        MsgBox "Failed to share the project."
    End If

End Sub


UndoCheckoutFiles

ISAWHAppObject::UndoCheckoutFiles

Description

Undoes the checkouts of multiple files.

Syntax

long UndoCheckoutFiles(
ISAWHUndoCheckoutFileSet* UndoCheckoutFileSet,,
Enum_LocalFileHandling LocalFileHandling,
 Enum_UndoCheckOutChangedFileHandling UndoCheckoutChangedFileHandling,
Enum_CompareFileBy CompareFileBy,
Enum_EOL EOL,
VARIANT_BOOL UseReadOnly,
Enum_SetLocalFileTime SetLocalFileTime,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

UndoCheckoutFileSet
[in] Specifies the full name set of the files to be undone checkout.

LocalFileHandling
[in] Specifies how to handle the local file after the checkout is undone.

UndoCheckoutChangedFileHandling
[in] Specifies how to handle the file if the local copy of the file has been changed.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

EOL
[in] Specifies which end-of-line terminator is to be used for files.

UseReadOnly
[in] Specifies whether to use read-only flag on files that are not checked out.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHUndoCheckoutFileSet Interface
  • ISAWHOperationResultSet Interface
  • Enum_LocalFileHandling Enumeration
  • Enum_UndoCheckOutChangedFileHandling Enumeration
  • Enum_CompareFileBy Enumeration
  • Enum_EOL Enumeration
  • Enum_SetLocalTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub UndoCheckoutFiles_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim UndoCheckoutFileSet As New SAWHUndoCheckoutFileSet
    Dim UndoCheckoutFile As New SAWHUndoCheckoutFile
    Dim OperationResultSet As New SAWHOperationResultSet

    UndoCheckoutFile.FileToUndo = "$/FileName.txt"
    UndoCheckoutFile.LocalFileName = "D:\LocalFileName.txt"
    UndoCheckoutFileSet.Add UndoCheckoutFile

    Dim ResultValue As Long
    ResultValue = sdkObject.UndoCheckoutFiles(UndoCheckoutFileSet, Enum_LeaveLocalFile, Enum_AskUndoCheckOutChangeFile, Enum_CompareFileByChecksum, Enum_EOLNative, False, Enum_SetLocalFileTimeCurrent, Cancelled, ResultDescription, OperationResultSet)
    If ResultValue <> 0 Then
        MsgBox "Failed to undo checkout of the file(s)."
    End If

End Sub


UndoCheckoutProject

ISAWHAppObject::UndoCheckoutProject

Description

Undoes the checkout of a project.

Syntax

long UndoCheckoutProject(
BSTR ProjectToUndo,
BSTR LocalFolder,
VARIANT_BOOL Recursive,
Enum_LocalFileHandling LocalFileHandling,
 Enum_UndoCheckOutChangedFileHandling UndoCheckoutChangedFileHandling,
Enum_CompareFileBy CompareFileBy,
Enum_EOL EOL,
VARIANT_BOOL UseReadOnly,
Enum_SetLocalFileTime SetLocalFileTime,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription,
ISAWHOperationResultSet* OperationResultSet
);

Parameters

ProjectToUndo
[in] Specifies the full name of the project to be undone checkout.

LocalFolder
[in] Specifies the local directory of the project.

Recursive
[in] Specifies whether checkout of the project is to be undone recursively.

LocalFileHandling
[in] Specifies how to handle the local file after the checkout is undone.

UndoCheckoutChangedFileHandling
[in] Specifies how to handle the file if the local copy of the file has been changed.

CompareFileBy
[in] Specifies how to determine if the local copy is up-to-date, by checksum or by date/time.

EOL
[in] Specifies which end-of-line terminator is to be used for files.

UseReadOnly
[in] Specifies whether to use read-only flag on files that are not checked out.

SetLocalFileTime
[in] Specifies the type of time to be assigned to the local file.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

OperationResultSet
[out] Returns the result information set of the operation.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

See Also

  • ISAWHOperationResultSet Interface
  • Enum_LocalFileHandling Enumeration
  • Enum_UndoCheckOutChangedFileHandling Enumeration
  • Enum_CompareFileBy Enumeration
  • Enum_EOL Enumeration
  • Enum_SetLocalTime Enumeration

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub UndoCheckoutProject_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim ProjectToUndo As String
    Dim LocalFolder As String
    Dim OperationResultSet As New SAWHOperationResultSet

    ProjectToUndo = "$/ProjectName"
    LocalFolder = "D:\ProjectToUndo"

    Dim ResultValue As Long
    ResultValue = sdkObject.UndoCheckoutProject(ProjectToUndo, LocalFolder, False, Enum_LeaveLocalFile, Enum_AskUndoCheckOutChangeFile, Enum_CompareFileByChecksum, Enum_EOLNative, False, Enum_SetLocalFileTimeCurrent, Cancelled, ResultDescription, OperationResultSet)
    If ResultValue <> 0 Then
        MsgBox "Failed to undo checkout of the project."
    End If

End Sub


UnpinFile

ISAWHAppObject::UnpinFile

Description

Unpins a file.

Syntax

l ong UnpinFile(
BSTR FileToUnpin,
BSTR* FileToUnpinned,
VARIANT_BOOL* Cancelled,
BSTR* ResultDescription
);

Parameters

FileToUnpin
[in] Specifies the full name of file to be unpinned.

FileToUnpinned
[out] Returns to the name of the file after it is unpinned.

Cancelled
[out] If the method fails, returns whether the operation is cancelled.

ResultDescription
[out] Returns the description of the return value. If the method succeeds, returns 'Completed'. If the method fails, returns the description of the error.

Return Value

If the method succeeds, returns 0. If the method fails, returns other error codes.

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub UnpinFile_Click()

    Dim Cancelled As Boolean
    Dim ResultDescription As String
    Dim FileToUnpin As String
    Dim FileToUnpinned As String

    FileToUnpin = "$/FileName.txt"

    Dim ResultValue As Long
    ResultValue = sdkObject.UnpinFile(FileToUnpin, FileToUnpinned, Cancelled, ResultDescription)
    If ResultValue <> 0 Then
        MsgBox "Failed to unpin the file."
    End If

End Sub


ISAWSActionType Interface

ISAWHActionType Interface

ISAWHActionType is the interface for storing action types.

The ISAWHActionType interface exposes the following methods.

  • Add
  • Clear

ISAWHActionType interface is used for the following method.

Interface | Method
ISAWHFileHistoryParam | SetActionType
ISAWHProjectHistoryParam | SetActionType


Add

ISAWHActionType::Add

Description

Adds an action type.

Syntax

HRESULT ObjectName.Add(Enum_ActionType ActionType)

Parameters

ActionType
[in] Specifies the action type.

Return Value

Returns the operation result.

See Also

  • Enum_ActionType Enumeration
  • ISAWHActionType Interface


Clear

ISAWHActionType::Clear

Description

Clears the action type.

Syntax

HRESULT ObjectName.Clear(Enum_ActionType ActionType)

Parameters

ActionType
[in] Specifies the action type.

Return Value

Returns the operation result.

See Also

  • Enum_ActionType Enumeration
  • ISAWHActionType Interface


ISAWSAddFile Interface

ISAWHAddFile Interface

ISAWHAddFile is the interface for storing file information when adding a file to the server.

The ISAWHAddFile interface exposes the following properties.

  • LocalFileName
  • RemoteFileName
  • FileType

ISAWHAddFile interface is used for the following method.

Interface | Method
ISAWHAddFileSet | Add


LocalFileName

ISAWHAddFile::LocalFileName

Description

Sets the path name of the local file to be added.

Syntax

string ObjectName.LocalFileName

See Also

  • ISAWHAddFile Interface


RemoteFileName

ISAWHAddFile::RemoteFileName

Description

Sets the full name of the server copy of the file. This name can be renamed different from the local file name.

Syntax

string ObjectName.RemoteFileName

See Also

  • ISAWHAddFile Interface


FileType

ISAWHAddFile::FileType

Description

Sets the type of the file.

Syntax

Enum_FileType ObjectName.FileType

See Also

  • ISAWHAddFile Interface
  • Enum_FileType Enumeration


ISAWSAddFileSet Interface

ISAWHAddFileSet Interface

ISAWHAddFileSet is the interface for managing ISAWHAddFile objects when adding files to server.

The ISAWHAddFileSet interface exposes the following method.

  • Add

ISAWHAddFileSet interface is used for the following method.

Interface | Method
ISAWHAppObject | AddFiles


Add

ISAWHAddFileSet::Add

Description

Adds information of a to-be-added file which is stored in ISAWHAddFile interface to ISAWHAddFileSet.

Syntax

boolean ObjectName.Add(ISAWHAddFile AddFile)

Parameters

AddFile
[in] Specifies the information of the file.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHAddFileSet Interface
  • ISAWHAddFile Interface


ISAWSBranchFileSet Interface

ISAWHBranchFileSet Interface

ISAWHBranchFileSet is the interface for storing the full name set of all branched files.

The ISAWHBranchFileSet interface exposes the following method.

  • Add

ISAWAddFileSet interface is used for the following method.

Interface | Method
ISAWHAppObject | BranchFiles


Add

ISAWHBranchFileSet::Add

Description

Adds the full name of a to-be-branched file to the name set ISAWHBranchFileSet.

Syntax

boolean ObjectName.Add(BSTR BranchFile)

Parameters

BranchFile
[in] Specifies the full name of the branched file.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHBranchFileSet Interface


ISAWSChangeSetIdInfo Interface

ISAWHChangeSetIdInfo Interface

ISAWHChangeSetIdInfo is the interface for storing information about a change set.

The ISAWHChangeSetIdInfo interface exposes the following properties.

  • ItemName
  • ItemIdLow
  • ItemIdHigh
  • ItemVersionLow
  • ItemVersionHigh
  • ActionDateTime
  • UserName
  • LabelName
  • ActionType
  • ActionDescription
  • Comment

ISAWHChangeSetIdInfo interface is used for the following method.

Interface | Method
ISAWHChangeSetIdInfoSet | Count Item _NewEnum ¡¡


ItemName

ISAWHChangeSetIdInfo::ItemName

Description

Returns the full name of the labeled item.

Syntax

string ObjectName.ItemName

See Also

  • ISAWHChangeSetIdInfo Interface


ItemIdLow

ISAWHChangeSetIdInfo::ItemIdLow

Description

Returns the low-order 32 bits of the item ID.

Syntax

long ObjectName.ItemIdLow

See Also

  • ISAWHChangeSetIdInfo Interface


ItemIdHigh

ISAWHChangeSetIdInfo::ItemId High

Description

Returns the high-order 32 bits of the item ID.

Syntax

long ObjectName.ItemIdHigh

See Also

  • ISAWHChangeSetIdInfo Interface


ItemVersionLow

ISAWHChangeSetIdInfo:ItemVersionLow

Description

Returns the low-order 32 bits of the item's version number.

Syntax

long ObjectName.ItemVersionLow

See Also

  • ISAWHChangeSetIdInfo Interface


ItemVersionHigh

ISAWHChangeSetIdInfo:ItemVersion High

Description

Returns the high-order 32 bits of the item's version number.

Syntax

long ObjectName.ItemVersionHigh

See Also

  • ISAWHChangeSetIdInfo Interface


ActionDateTime

ISAWHChangeSetIdInfo::ActionDateTime

Description

Returns the date/time of the action.

Syntax

DATE ObjectName.ActionDateTime

See Also

  • ISAWHChangeSetIdInfo Interface


UserName

ISAWHChangeSetIdInfo::UserName

Description

Returns the name of the user who adds the label.

Syntax

string ObjectName.UserName

See Also

  • ISAWHChangeSetIdInfo Interface


LabelName

ISAWHChangeSetIdInfo::LabelName

Description

Returns the label name.

Syntax

string ObjectName.LabelName

See Also

  • ISAWHChangeSetIdInfo Interface


ActionType

ISAWHChangeSetIdInfo::ActionType

Description

Returns the action type.

Syntax

string ObjectName.ActionType

See Also

  • ISAWHChangeSetIdInfo Interface
  • ISAWHActionType Interface


ActionDescription

ISAWHChangeSetIdInfo::ActionDescription

Description

Returns the description of the action.

Syntax

string ObjectName.ActionDescription

See Also

  • ISAWHChangeSetIdInfo Interface


Comment

ISAWHChangeSetIdInfo::Comment

Description

Returns the comment of the change set (if any).

Syntax

string ObjectName.Comment

See Also

  • ISAWHChangeSetIdInfo Interface


ISAWSChangeSetIdInfoSet Interface

ISAWHChangeSetIdInfoSet Interface

ISAWHChangeSetIdInfoSet is the interface for managing ISAWHChangeSetIdInfo objects.

The ISAWHChangeSetIdInfoSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHChangeSetIdInfoSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetChangeSetIdInfo


GetCount

ISAWHChangeSetIdInfoSet::Count

Description

Returns the number of change set.

Syntax

long ObjectName.Count()

Parameters

No Parameter.

Return Value

Returns the number of change set.


Get

ISAWSChangeSetIdInfoSet::Item

Description

Retrieves the general information about the changeset.

Syntax

VARIANT* ObjectName.Item(long Index)

Parameters

Index
[in] Specifies the index number of the change set.

Return Value

Returns a changeset.

See Also

  • ISAWHChangeSetIdInfoSet Interface
  • ISAWHChangeSetIdInfo Interface


ISAWHChangeSetIdInfoSet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* _NewEnum()

Parameters

No Parameter.

Return Value

Returns the collection to be iterated over.


ISAWSCheckinFile Interface

ISAWHCheckinFile Interface

ISAWHCheckinFile is the interface for storing file information when checking in a file.

The ISAWHCheckinFile interface exposes the following properties.

  • FileToCheckin
  • LocalFileName

ISAWHCheckinFile interface is used for the following method.

Interface | Method
ISAWHCheckinFileSet | Add


FileToCheckin

ISAWHCheckinFile::FileToCheckin

Description

Sets the full name of the server file to be checked in.

Syntax

string ObjectName.FileToCheckin

See Also

  • ISAWHCheckinFile Interface


LocalFileName

ISAWHCheckinFile::LocalFileName

Description

Sets the path name of the local file copy to be checked in.

Syntax

string ObjectName.LocalFileName

See Also

  • ISAWHCheckinFile Interface


ISAWSCheckintFileSet Interface

ISAWHCheckinFileSet Interface

ISAWHCheckinFileSet is the interface for managing ISAWHCheckinFile objects.

The ISAWHCheckinFileSet interface exposes the following method.

  • Add

ISAWHCheckinFileSet interface is used for the following method.

Interface | Method
ISAWHAppObject | CheckInFiles


Add

ISAWHCheckinFileSet::Add

Description

Adds information of a to-be-checked-in file which is stored in ISAWHCheckinFile interface to the information set ISAWHCheckinFileSet.

Syntax

boolean ObjectName.Add(ISAWHCheckinFile* CheckinFile)

Parameters

CheckinFile
[in] Specifies the information of the file to be checked in.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHCheckinFileSet Interface
  • ISAWHCheckinFile Interface


ISAWSCheckoutFile Interface

ISAWHCheckoutFile Interface

ISAWHCheckoutFile is the interface for storing file information when checking out a file.

The ISAWHCheckoutFile interface exposes the following properties.

  • FileToCheckout
  • LocalFileName

ISAWHCheckoutFile interface is used for the following method.

Interface | Method
ISAWHCheckoutFileSet | Add


FileToCheckout

ISAWHCheckoutFile::FileToCheckout

Description

Sets the full name of the file.

Syntax

string ObjectName.FileToCheckout

See Also

  • ISAWHCheckoutFile Interface


LocalFileName

ISAWHCheckoutFile::LocalFileName

Description

Sets the path name of the local file copy.

Syntax

string ObjectName.LocalFileName

See Also

  • ISAWHCheckoutFile Interface


ISAWSCheckoutFileSet Interface

ISAWHCheckoutFileSet Interface

ISAWHCheckoutFileSet is the interface for managing ISAWHCheckoutFile objects.

The ISAWHCheckoutFileSet interface exposes the following methods.

  • Add

ISAWHCheckoutFileSet interface is used for the following method.

Interface | Method
ISAWHAppObject | CheckoutFiles


Add

ISAWHCheckoutFileSet::Add

Description

Adds information of a to-be-checked-out file which is stored in ISAWHCheckoutFile interface to the information set ISAWHCheckoutFileSet.

Syntax

Boolean ObjectName.Add(ISAWHCheckoutFile* CheckoutFile)

Parameters

CheckoutFile
[in] Specifies the name information of the file to be checked out.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHCheckoutFileSet Interface
  • ISAWHCheckoutFile Interface


ISAWSCheckoutFileStatus Interface

ISAWHCheckoutFileStatus Interface

ISAWHCheckoutFileStatus is the interface for storing general information about a checked-out file.

The ISAWHCheckoutFileStatus interface exposes the following properties.

  • CheckoutUserName
  • Comment
  • CheckoutDateTime
  • VersionNumberLow
  • VersionNumberHigh

ISAWHCheckoutFileStatus interface is used for the following method.

Interface | Method
ISAWHCheckoutFileStatusSet | Count Item New Enum ¡¡


CheckoutUserName

ISAWHCheckoutFileStatus::CheckoutUserName

Description

Returns the name of the user who have the file checked out.

Syntax

string ObjectName.CheckoutUserName

See Also

  • ISAWHCheckoutFileStatus Interface


Comment

ISAWHCheckoutFileStatus::Comment

Description

Returns the comment on the checkout of the file.

Syntax

string ObjectName.Comment

See Also

  • ISAWHCheckoutFileStatus Interface


CheckoutDateTime

ISAWHCheckoutFileStatus::CheckoutDateTime

Description

Returns the date/time when the file is checked out.

Syntax

DATE ObjectName.CheckoutDateTime

See Also

  • ISAWHCheckoutFileStatus Interface


VersionNumberLow

ISAWHCheckoutFileStatus::VersionNumberLow

Description

Returns the low-order 32 bits of the file version number.

Syntax

long ObjectName.VersionNumberLow

See Also

  • ISAWHCheckoutFileStatus Interface


VersionNumberHigh

ISAWHCheckoutFileStatus::VersionNumberHigh

Description

Returns the high-order 32 bits of the file version number.

Syntax

long ObjectName.VersionNumberHigh

See Also

  • ISAWHCheckoutFileStatus Interface


ISAWSCheckoutFileStatusSet Interface

ISAWHCheckoutFileStatusSet Interface

ISAWHCheckoutFileStatus the interface for managing ISAWHCheckoutFileStatus objects.

The ISAWHCheckoutFileStatus interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHCheckoutFileStatus interface is used for the following method.

Interface | Method
ISAWHAppObject | GetFileCheckoutStatus


GetCount

ISAWHCheckoutFileStatusSet::Count

Description

Returns the number of files.

Syntax

long ObjectName.Count()

Parameters

No parameter.

Return Value

Returns the number of files.

See Also

  • ISAWHCheckoutFileStatusSet Interface
  • ISAWHCheckoutFileStatus Interface


Get

ISAWHCheckoutFileStatusSet::Item

Description

Retrieves the the general information about a checked out file.

Syntax

VARIANT* ObjectName.Item(long Index)

Parameters

Index
[in] Specifies the index number of the file.

Return Value

Returns the status of a checked-out file.

See Also

  • ISAWHCheckoutFileStatusSet Interface
  • ISAWHCheckoutFileStatus Interface


ISAWHCheckoutFileStatusSet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* ObjectName._NewEnum()

Parameters

No parameter.

Return Value

Returns the collection to be iterated over.

See Also

  • ISAWHCheckoutFileStatusSet Interface
  • ISAWHCheckoutFileStatus Interface


ISAWSDeleteFileSet Interface

ISAWHDeleteFileSet Interface

ISAWHDeleteFileSet is the interface for storing the name set of files to be deleted.

The ISAWHDeleteFileSet interface exposes the following method.

  • Add

ISAWHDeleteFileSet is used for the following method.

Interface | Method
ISAWHAppObject | DeleteFiles


Add

ISAWHDeleteFileSet::Add

Description

Adds the name of a to-be-deleted file to the name set.

Syntax

boolean ObjectName.Add(BSTR DeleteFileName)

Parameters

DeleteFileName
[in] Specifies the name of a file to be deleted.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHDeleteFileSet Interface


EnumActionType

Enum_ActionType Enum

Description

Indicates the type of source control action.

It is used with the following methods and properties.

Interface | Method
ISAWHFileHistoryParam | SetActionType()
ISAWHProjectHistoryParam | SetActionType()
ISAWHActionType | Add()
ISAWHActionType | Clear()
Interface | Property
ISAWHChangeSetIdInfo | ActionType
ISAWHHistory | ActionType

Constants

Name | Value | Description
Enum_ActionTypeNull | 0x00000000 | No action displayed.
Enum_ActionTypeAdd | 0x00000001 | Displays the Add action, which adds files or subproject to a project in the repository.
Enum_ActionTypeDelete | 0x00000002 | Displays the Delete action, which removes files or projects from the repository, and marks them as deleted.
Enum_ActionTypeRecover | 0x00000004 | Displays the Recover action, which recovers a deleted item.
Enum_ActionTypeCheckin | 0x00000008 | Displays the Check In action, which updates the checked-out item with modifications made to it.
Enum_ActionTypeRename | 0x00000010 | Displays the Rename action, which renames a file or a project.
Enum_ActionTypeMoveOut | 0x00000020 | Displays the Move action, which moves an item out of a project.
Enum_ActionTypeMoveIn | 0x00000040 | Displays the Move action, which moves an item into a project.
Enum_ActionTypeShare | 0x00000080 | Displays the Share action, which shares an item among multiple projects.
Enum_ActionTypeBranch | 0x00000100 | Displays the Branch action, which breaks the share link while retaining a copy of the file, or copies the selected history version of an item to a specified location.
Enum_ActionTypeRollback | 0x00000800 | Displays the Rollback action, which goes back to a history version of a file while retaining the history of changes made after that version.
Enum_ActionTypeInheritedForVersionTracking | 0x00001000 | Unused parameter.
Enum_ActionTypeLabel | 0x00004000 | Displays the Label action, which assigns a label to the specified version of a file or project.
Enum_ActionTypePin | 0x00020000 | Displays the Pin action, which pins the current or history version of an item.
Enum_ActionTypeUnpin | 0x00040000 | Displays the Unpin action, which unpins the current or history version of an item.
Enum_ActionTypePurge | 0x00080000 | Displays the Purge action, which permanently removes an item that is deleted.
Enum_ActionTypeForParentDisplay | 0x00100000 | Displays all actions on an item's parent project.
Enum_ActionTypeAddForParentDisplay | 0x00200000 | Displays the Add action on an item's parent project.
Enum_ActionTypeDeleteForParentDisplay | 0x00400000 | Displays the Delete action on an item's parent project.
Enum_ActionTypeRecoverForParentDisplay | 0x00800000 | Displays the Recover action on an item's parent project.
Enum_ActionTypePurgeForParentDisplay | 0x01000000 | Displays the Purge action on an item's parent project.
Enum_ActionTypeRenameForParentDisplay | 0x02000000 | Displays the Rename action on an item's parent project.
Enum_ActionTypeShareForParentDisplay | 0x04000000 | Displays the Share action on an item's parent project.
Enum_ActionTypeBranchForParentDisplay | 0x08000000 | Displays the Branch action on an item's parent project.
Enum_ActionTypeMoveInForParentDisplay | 0x10000000 | Displays the Move In action on an item's parent project.
Enum_ActionTypeMoveOutForParentDisplay | 0x20000000 | Displays Move Out action on an item's parent project.


Add

ISAWHDeleteProjectSet::Add

Description

Adds the name of a to-be-deleted project to the name set.

Syntax

boolean ObjectName.Add(BSTR ProjectName)

Parameters

ProjectName
[in] Specifies the name of a project to be deleted.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHDeleteFileSet Interface


ISAWSDeletedItemGeneralInfo Interface

ISAWHDeletedItemGeneralInfo Interface

ISAWHDeletedItemGeneralInfo is the interface for storing deleted (not purged) item information on the server.

The ISAWHDeletedItemGeneralInfo interface exposes the following properties.

  • IsProject
  • ItemName
  • ItemIdLow
  • ItemIdHigh

ISAWHDeletedItemGeneralInfo interface is used for the following method.

Interface | Method
ISAWHDeletedItemGeneralInfoSet | Count Item _NewEnum ¡¡


IsProject

ISAWHDeletedItemGeneralInfo::IsProject

Description

Returns whether the deleted item is a project.

Syntax

boolean ObjectName.IsProject

See Also

  • ISAWHDeletedItemGeneralInfo Interface


ItemName

ISAWHDeletedItemGeneralInfo::ItemName

Description

Returns the full name of a deleted item.

Syntax

string ObjectName.ItemName

See Also

  • ISAWHDeletedItemGeneralInfo Interface


ItemIdLow

ISAWHDeletedItemGeneralInfo::ItemIdLow

Description

Returns the low-order 32 bits of the deleted item ID.

Syntax

string ObjectName.ItemIdLow

See Also

  • ISAWHDeletedItemGeneralInfo Interface


ItemIdHigh

ISAWHDeletedItemGeneralInfo::ItemIdHigh

Description

Returns the high-order 32 bits of the deleted item ID.

Syntax

long ObjectName.ItemIdHigh

See Also

  • ISAWHDeletedItemGeneralInfo Interface


ISAWSDeletedItemGeneralInfoSet Interface

ISAWHDeletedItemGeneralInfoSet Interface

ISAWHDeletedItemGeneralInfoSet is the interface for managing ISAWHDeletedItemGeneralInfo objects.

The ISAWHDeletedItemGeneralInfoSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHDeletedItemGeneralInfoSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetProjectGeneralInfo


GetCount

ISAWHDeletedItemGeneralInfoSet::Count

Description

Returns the number of deleted items in the project.

Syntax

long ObjectName.Count()

Parameters

No parameter.

Return Value

Returns the number of deleted items in the project.

See Also

  • ISAWHDeletedItemGeneralInfoSet Interface
  • ISAWHDeletedItemGeneralInfo Interface


Get

ISAWSDeletedItemGeneralInfoSet::Item

Description

Retrieves the information of a deleted item.

Syntax

VARIANT* ObjectName.Item(Long Index)

Parameters

Index
[in] Specifies the index number of the deleted item.

Return Value

Returns the information of a deleted item.

See Also

  • ISAWHDeletedItemGeneralInfoSet Interface
  • ISAWHDeletedItemGeneralInfo Interface


ISAWHDeletedItemGeneralInfoSet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* _NewEnum()

Parameters

No Parameter.

Return Value

Returns the collection to be iterated over.


ISAWSDeleteItemFromLabel Interface

ISAWHDeleteItemFromLabel Interface

ISAWHDeleteItemFromLabel is the interface for storing the the information about the deleted items in a label.

The ISAWHDeleteItemFromLabel interface exposes the following properties.

  • Description
  • Successful
  • HistoryIdLow
  • HistoryIdHigh

ISAWHDeleteItemFromLabel interface is used for the following method.

Interface | Method
ISAWHDeleteItemFromLabelSet | Get


Description

ISAWHDeleteItemFromLabel::Description

Description

Returns the description of the deleted item from a label.

Syntax

string ObjectName.Description

See Also

  • ISAWHDeleteItemFromLabel Interface


Successful

ISAWHDeleteItemFromLabel::Successful

Description

Returns whether the item is successfully removed from the label.

Syntax

long ObjectName.Successful

See Also

  • ISAWHDeleteItemFromLabel Interface


HistoryIdLow

ISAWHDeleteItemFromLabel::HistoryId Low

Description

Returns the low-order 32 bits of the history record ID.

Syntax

long ObjectName.HistoryId Low

See Also

  • ISAWHDeleteItemFromLabel Interface


HistoryIdHigh

ISAWHDeleteItemFromLabel::HistoryId High

Description

Returns the high-order 32 bits of the history record ID.

Syntax

long ObjectName.HistoryIdHigh

See Also

  • ISAWHDeleteItemFromLabel Interface


ISAWSDeleteItemFromLabelSet Interface

ISAWHDeleteItemFromLabelSet Interface

ISAWHDeleteItemFromLabelSet is the interface for managing ISAWHDeleteItemFromLabel objects.

The ISAWHDeleteItemFromLabelSet interface exposes the following methods.

  • Add
  • GetCount
  • Get

ISAWHDeleteItemFromLabelSet interface is used for the following method.

Interface | Method
ISAWHAppObject | DeleteItemsFromLabel


Add

ISAWHDeleteItemFromLabelSet::Add

Description

Adds the general information about a to-be-deleted-from-label item to ISAWDeleteItemFromLabelSet.

Syntax

boolean Add(ISAWHDeleteItemFromLabel* DeleteItemFromLabel)

Parameters

DeleteItemFromLabel
[in] Specifies the general information about the to-be-deleted-from-label item.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHDeleteItemFromLabelSet Interface
  • ISAWHDeleteItemFromLabel Interface


GetCount

ISAWHDeleteItemFromLabelSet::GetCount

Description

Returns the number of to-be-deleted-from-label items.

Syntax

long ObjectName.GetCount()

Parameters

No Parameter.

Return Value

Returns the number of to-be-deleted-from-label items.

See Also

  • ISAWHDeleteItemFromLabelSet Interface
  • ISAWHDeleteItemFromLabel Interface


Get

ISAWHDeleteItemFromLabelSet::Get

Description

Retrieves the information of a to-be-deleted-from-label item.

Syntax

boolean Get(long Index, ISAWHDeleteItemFromLabel* DeleteItemFromLabel)

Parameters

Index
[in] Specifies the index number of the deleted item from label.

PurgeItem
[in] Specifies the general information about the deleted item from label.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHDeleteItemFromLabelSet Interface
  • ISAWHDeleteItemFromLabel Interface


ISAWSDiffMergeParam Interface

ISAWHDiffMergeParam Interface

ISAWHDiffMergeParam is the interface for storing the parameters used for merge.

The ISAWHDiffMergeParam interface exposes the following properties.

  • Reserved
  • DiffFileArguments
  • DiffDirArguments
  • ThreeWayMergeArguments
  • DiffMergeTool

ISAWHDiffMergeParam interface is used for the following methods:

Interface Method
ISAWHAppObject CheckInFiles()
CheckInProject()
CheckOutFiles()
CheckOutProject()
GetLatestFiles()
GetLatestProject()
GetLatestProjects()
GetOldVersionFile()


Reserved

ISAWHDiffMergeParam::Reserved

Description

Sets the handle to window.

Syntax

long ObjectName.Reserved();

See Also

  • ISAWHDiffMergeParam Interface


DiffFileArguments

ISAWHDiffMergeParam::DiffFileArguments

Description

Specifies the arguments to supply for files comparison when the diff tool is invoked. The following macros are available (the macros are case-sensitive):

  • %FIRST_FILE% - expands to the path of the file that will be supplied for the left side of the diff output.
  • %SECOND_FILE% - expands to the path of the file that will be supplied for the right side of the diff output.
  • %FIRST_LABEL% - expands to the label that will be supplied to the file being diffed on the left side of the diff output.
  • %SECOND_LABEL% - expands to the label that will be supplied to the file being diffed on the right side of the diff output.

For example, to invoke windiff to compare two files from command line, the command is as follows:

Windiff path_to_first_file path_to_second_file

So, the entry for this field that is appropriate for the external diff tool Windiff is:

"%FIRST_FILE%" "%SECOND_FILE%"

Syntax

long ObjectName.DiffFileArguments;

See Also

  • ISAWHDiffMergeParam Interface


DiffDirArguments

ISAWHDiffMergeParam::DiffDirArguments

Description

Specifies the arguments to supply for directory comparison when the diff tool is invoked. The following macros are available (the macros are case-sensitive):

  • %FIRST_DIR% - expands to the path of the directory that will be supplied for the left side of the diff output.
  • %SECOND_DIR% - expands to the path of the directory that will be supplied for the right side of the diff output.
  • %FIRST_LABEL% - expands to the label that will be supplied to the directory being diffed on the left side of the diff output.
  • %SECOND_LABEL% - expands to the label that will be supplied to the directory being diffed on the right side of the diff output.

Syntax

string ObjectName.DiffDirArguments;

See Also

  • ISAWHDiffMergeParam Interface


ThreeWayMergeArguments

ISAWHDiffMergeParam::ThreeWayMergeArguments

Description

Specifies the arguments for the three-way merge. This parameter allows you to specify the arguments to supply for three-way merge when the merge tool is invoked. The following macros are available (the macros are case-sensitive):

  • %BASE_FILE% - expands to the path of the file that is the common ancestor, or baseline between the two files being merged.
  • %THEIRS_FILE% - expands to the path of the updated server file that is being merged.
  • %YOURS_FILE% - expands to the path of your local file that is being merged.
  • %RESULT_FILE% - expands to the path of file that will be saved when the user merges the files together.
  • %FIRST_LABEL% - expands to the label supplied by the merge tool to put on top of the first file being merged.
  • %SECOND_LABEL% - expands to the label supplied by the merge tool to put on top of the second file being merged.

For example, to invoke MergeHero.jar to merge three files, the entry for this field is as follows:

"C:/Program files/MergeHero.exe" -merge -ignoreEOL "%BASE_FILE%" "%THEIRS_FILE%" "%YOURS_FILE%" "%RESULT_FILE%" -leftlabel "%FIRST_LABEL%" -rightlabel "%SECOND_LABEL%"

(In this example, the merge, ignoreEOL, leftlabel and rightlabel are parameters of MergeHero.)

Syntax

string ObjectName.ThreeWayMergeArguments;

See Also

  • ISAWHDiffMergeParam Interface


DiffMergeTool

ISAWHDiffMergeParam::DiffMergeTool

Description

Specifies the path of the merge utility to use.

Syntax

string ObjectName.DiffMergeTool;

See Also

  • ISAWHDiffMergeParam Interface


ISAWSFileCommonInfo Interface

ISAWHFileCommonInfo Interface

ISAWHFileCommonInfo is the interface for storing the common information about a file.

The ISAWHFileCommonInfo interface exposes the following properties.

  • FileName

  • CheckoutUser

  • IsMergable

  • ItemStatus

  • ModificationDateTime

  • CheckinDateTime

  • Successful

  • Description

  • FileLengthLow

  • FileLengthHigh

  • VersionNumberLow

  • VersionNumberHigh

ISAWHCommonInfo interface is used for the following method.

Interface | Method
ISAWHCommonInfoSet | Get


FileName

ISAWHFileCommonInfo::FileName

Description

Returns the full name of a file.

Syntax

string ObjectName.FileName

See Also

  • ISAWHFileCommonInfo Interface


CheckoutUser

ISAWHFileCommonInfo::CheckoutUser

Description

Returns name of the user who have the file checked out.

Syntax

string ObjectName.CheckoutUser

See Also

  • ISAWHFileCommonInfo Interface


IsMergeable

ISAWHFileCommonInfo::IsMergeable

Description

Returns whether the file is mergeable.

Syntax

boolean ObjectName.Mergeable

See Also

  • ISAWHFileCommonInfo Interface


ItemStatus

ISAWHFileCommonInfo::ItemStatus

Description

Returns the file status.

Syntax

Enum_ItemStatus ObjectName.ItemStatus

See Also

  • ISAWHFileCommonInfo Interface


ModificationDateTime

ISAWHFileCommonInfo::ModificationDateTime

Description

Returns the modification date/time of the file.

Syntax

DATE ObjectName.ModificationDateTime

See Also

  • ISAWHFileCommonInfo Interface


CheckinDateTime

ISAWH FileCommonInfo::CheckinDateTime

Description

Returns the check-in date/time of the file.

Syntax

DATE ObjectName.CheckinDateTime

See Also

  • ISAWHFileCommonInfo Interface


Successful

ISAWHFileCommonInfo::Successful

Description

Returns whether successfully retrieves the file's common information.

Syntax

boolean ObjectName.Successful

See Also

  • ISAWHFileCommonInfo Interface


Description

ISAWHFileCommonInfo::Description

Description

Returns the description of the file.

Syntax

string ObjectName.Description

See Also

  • ISAWHFileCommonInfo Interface


FileLengthLow

ISAWHFileCommonInfo::FileLengthLow

Description

Returns the low-order 32 bits of the file size.

Syntax

long ObjectName.FileLengthLow

See Also

  • ISAWHFileCommonInfo Interface


FileLengthHigh

ISAWHFileCommonInfo::FileLengthHigh

Description

Returns the high-order 32 bits of the file size.

Syntax

long ObjectName.FileLengthHigh

See Also

  • ISAWHFileCommonInfo Interface


VersionNumberLow

ISAWHFileCommonInfo::VersionNumberLow

Description

Returns the low-order 32 bits of the file's version number.

Syntax

long ObjectName.VersionNumberLow

See Also

  • ISAWHFileCommonInfo Interface


VersionNumberHigh

ISAWHFileCommonInfo::VersionNumberHigh

Description

Returns the high-order 32 bits of the file's version number.

Syntax

long ObjectName.VersionNumberHigh

See Also

  • ISAWHFileCommonInfo Interface


ISAWSFileCommonInfoSet Interface

ISAWHFileCommonInfoSet Interface

ISAWHFileCommonInfoSet is the interface for managing ISAWHFileCommonInfo objects.

The ISAWHFileCommonInfoSet interface exposes the following methods.

  • Add
  • GetCount
  • Get

ISAWHDeleteItemFromLabelSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetFilesCommonInfo


Add

ISAWHFileCommonInfoSet::Add

Description

Adds the common information about a file to ISAWHFileCommonInfoSet.

Syntax

boolean Add(ISAWHFileCommonInfo* FileCommonInfo)

Parameters

FileCommonInfo
[in] Specifies the common information about a file.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHFileCommonInfoSet Interface
  • ISAWHFileCommonInfo Interface


GetCount

ISAWHFileCommonInfoSet::GetCount

Description

Returns the number of files.

Syntax

long ObjectName.GetCount()

Parameters

No Parameter.

Return Value

Returns the number of files.

See Also

  • ISAWHFileCommonInfoSet Interface
  • ISAWHFileCommonInfo Interface


Get

ISAWHFileCommonInfoSet::Get

Description

Retrieves the common information of a file.

Syntax

boolean Get(long Index, ISAWHFileCommonInfo* FileCommonInfo)

Parameters

Index
[in] Specifies the index number of the file.

FileCommonInfo
[out] Specifies the common information about the file.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHFileCommonInfoSet Interface
  • ISAWHFileCommonInfo Interface


ISAWSFileHistoryParam Interface

ISAWHFileHistoryParam Interface

ISAWHFileHistoryParam is the interface for storing parameters used to filter the file history record.

The ISAWHFileHistoryParam interface exposes the following methods and properties.

  • AddUser
  • IsIncludedAnyComment
  • CommentSubString
  • DateFrom
  • DateTo
  • AddOrder
  • SetActionType

ISAWHFileHistoryParam interface is used for the following method.

Interface | Method
ISAWHAppObject | GetFileHistory


AddUser

ISAWHFileHistoryParam::AddUser

Description

Filters the history record by user.

Syntax

boolean ObjectName.AddUser(BSTR UserName)

Parameter

UserName
[in] Specifies the user name.

See Also

  • ISAWHFileHistoryParam Interface


IsIncludedAnyComment

ISAWHFileHistoryParam::IsIncludedAnyComment

Description

Specifies whether to filter the history record by comments.

Syntax

boolean ObjectName.IsIncludedAnyComment

See Also

  • ISAWHFileHistoryParam Interface


CommentSubString

ISAWHFileHistoryParam::CommentSubString

Description

Filters the file history by the comments that match the substring.

Syntax

boolean ObjectName.CommnetSubString

See Also

  • ISAWHFileHistoryParam Interface


DateFrom

ISAWHFileHistoryParam::DateFrom

Description

Restricts the history report to begin at the date specified.

Syntax

Date ObjectName.DateFrom

See Also

  • ISAWHFileHistoryParam Interface


DateTo

ISAWHFileHistoryParam::DateTo

Description

Restricts the history report to end at the date specified.

Syntax

Date ObjectName.DateTo

See Also

  • ISAWHFileHistoryParam Interface


AddOrder

ISAWHFileHistoryParam::AddOrder

Description

Sorts the history by the specific item.

Syntax

boolean ObjectName.AddOrder(ISAWHHistoryOrderBy* HistoryOrderBy)

Parameter

HistoryOrderBy
[in] Specifies the item used to sort the history record.

See Also

  • ISAWHFileHistoryParam Interface
  • ISAWHHistoryOrderBy Interface


SetActionType

ISAWHFileHistoryParam::SetActionType

Description

Restricts the history report to the selected actions.

Syntax

HRESULT ObjectName.SetActionType(ISAWHActionType* ActionType);

Parameter

ActionType
[in] Specifies the action type, such as Add, Delete, Check In and others.

See Also

  • ISAWHFileHistoryParam Interface
  • ISAWHActionType Interface


ISAWSFileStatusInSet Interface

ISAWHFileStatusInSet Interface

ISAWHFileStatusInSet is the interface for storing the name set of files.

The ISAWHFileStatusInSet interface exposes the following method.

  • Add

ISAWHFileStatusInSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetFilesStatus


Add

ISAWHFileStatusInSet::Add

Description

Specifies the file name.

Syntax

boolean ObjectName.Add(BSTR* FileName)

Parameters

FileName
[in] Specifies the file name.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHFileStatusInSet Interface


ISAWSFileStatusOut Interface

ISAWHFileStatusOut Interface

ISAWHFileStatusOut is the interface for storing file status information.

The ISAWHFileStatusOut interface exposes the following properties.

  • FileStatus
  • IsExists
  • IsCheckoutByMe

ISAWHFileStatusOut interface is used for the following method.

Interface | Method
ISAWHFileStatusOutSet | Count Item _NewEnum ¡¡


FileStatus

ISAWHFileStatusOut::FileStatus

Description

Returns the status of the file.

Syntax

Enum_ItemStatus ObjectName.FileStatus

See Also

  • ISAWHFileStatusOut Interface


IsExists

ISAWHFileStatusOut::IsExists

Description

Returns whether the file exists in the repository.

Syntax

boolean ObjectName.IsExists

See Also

  • ISAWHFileStatusOut Interface


IsCheckoutByMe

ISAWHFileStatusOut::IsCheckoutByMe

Description

Returns whether the file is checked out by the current user.

Syntax

boolean ObjectName.IsCheckoutByMe

See Also

  • ISAWHFileStatusOut Interface


ISAWSFileStatusOutSet Interface

ISAWHFileStatusOutSet Interface

ISAWHFileStatusOutSet is the interface for managing ISAWHFileStatusOut objects.

The ISAWHFileStatusOutSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHOperationResultSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetFilesStatus


GetCount

ISAWHFileStatusOutSet::Count

Description

Returns the number of files.

Syntax

long ObjectName.Count()

Parameters

No parameter.

Return Value

Returns the piece number of files.

See Also

  • ISAWHFileStatusOutSet Interface
  • ISAWHFileStatusOut Interface


ISAWHFileStatusOutSet::Item

Description

Retrieves the the status information of a file.

Syntax

VARIANT* ObjectName.Item(long Index)

Parameters

Index
[in] Specifies the index number of the file.

Return Value

Returns the status information of a file.

See Also

  • ISAWHFileStatusOutSet Interface
  • ISAWHFileStatusOut Interface


ISAWSFileListSet Interface

ISAWHFileListSet Interface

ISAWHFileListSet is the interface for storing the name set of all files in a project.

The ISAWHFileListSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHFileListSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetFileListFromProject


GetCount

ISAWHFileListSet::Count

Description

Returns the number of files in project.

Syntax

long ObjectName.GetCount()

Parameters

No parameter.

Return Value

Returns the number of files in the project.

See Also

  • ISAWHFileListSet Interface


ISAWHFileListSet::Item

Description

Retrieves the file name.

Syntax

BSTR* Item(Long Index)

Parameters

Index
[in] Specifies the index number of the file.

Return Value

Returns the file name.

See Also

  • ISAWHFileListSet Interface


ISAWHFileListSet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* _NewEnum()

Parameters

No Parameter.

Return Value

Returns the collection to be iterated over.


ISAWSWebProject Interface

ISAWHGlobalMessage Interface

ISAWHGlobalMessage is the interface for storing the information about a piece of global message.

The ISAWHGlobalMessage interface exposes the following properties.

  • MessageID

  • MessageContent

  • MessageTitle

  • MessagePublishTime

ISAWHGlobalMessage interface is used for the following method.

Interface | Method
ISAWHGlobalMessageSet | Count Item _NewEnum ¡¡


DeployName

ISAWHGlobalMessage::MessageTitle

Description

Specifies the title of the global message.

Syntax

string ObjectName.MessageTitle

See Also

  • ISAWHGlobalMessage Interface


ItemName

ISAWHGlobalMessage::PublishTime

Description

Specifies when the global message is published.

Syntax

string ObjectName.PublishTime

See Also

  • ISAWHGlobalMessage Interface


DeployName

ISAWHGlobalMessage::MessageID

Description

Specifies the identity of the global message.

Syntax

string ObjectName.MessageID

See Also

  • ISAWHGlobalMessage Interface


ItemName

ISAWHGlobalMessage::MessageContent

Description

Specifies the content of the global message.

Syntax

string ObjectName.MessageContent

See Also

  • ISAWHGlobalMessage Interface


ISAWSWebProjectSet Interface

ISAWHGlobalMessageSet Interface

ISAWHGlobalMessageSet is the interface for managing ISAWHGlobalMessage objects.

The ISAWHGlobalMessageSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHGlobalMessageSet interface is used for the following method.

Interface | Method
ISAWHAppObject | ConnectToServer


GetCount

ISAWHGlobalMessageSet::Count

Description

Returns the number of global messages.

Syntax

long ObjectName.GetCount()

Parameters

No Parameter.

Return Value

Returns the number of global messages.

See Also

  • ISAWHGlobalMessageSet Interface
  • ISAWHGlobalMessage Interface


ISAWHGlobalMessageSet::Item

Description

Retrieves a piece of global message.

Syntax

VARIANT* ObjectName.Item(Long Index)

Parameters

Index
[in] Specifies the index number of the global message.

Return Value

Returns a piece of global message.

See Also

  • ISAWHGlobalMessageSet Interface
  • ISAWHGlobalMessage Interface


ISAWHGlobalMessageSet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* _NewEnum()

Parameters

No Parameter.

Return Value

Returns the collection to be iterated over.


ISAWSHistory Interface

ISAWHHistory Interface

ISAWHProjectHistory is the interface for storing a piece of history record of an item.

The ISAWHProjectHistory interface exposes the following properties.

  • ModificationDateTime
  • CheckinDateTime
  • ActionDateTime
  • IsMergable
  • IsProject
  • ActionType
  • ActionDescription
  • UserName
  • LabelName
  • Comment
  • IsPinned
  • ItemName
  • ChangeSetIdLow
  • ChangeSetIdHigh
  • HistoryIdLow
  • HistoryIdHigh
  • VersionNumberLow
  • VersionNumherHigh
  • FileSizeLow
  • FileSizeHigh
  • ItemIdLow
  • ItemIdHigh

ISAWHHistory interface is used for the following method.

Interface | Method
ISAWHHistorySet | Count Item _NewEnum ¡¡


ModificationDateTime

ISAWHHistory::ModificationDateTime

Description

Returns the modification date/time of the history item.

Syntax

DATE ObjectName.ModificationDateTime

See Also

  • ISAWHHistory Interface


CheckinDateTime

ISAWHHistory::CheckinDateTime

Description

Returns the check-in date/time of the history item.

Syntax

DATE ObjectName.CheckinDateTime

See Also

  • ISAWHHistory Interface


IsMergeable

ISAWHHistory::IsMergeable

Description

Returns whether the item is mergeable.

Syntax

boolean ObjectName.IsMergeable

See Also

  • ISAWHHistory Interface


IsProject

ISAWHHistory::IsProject

Description

Returns whether the item is a project.

Syntax

boolean ObjectName.IsProject

See Also

  • ISAWHHistory Interface


ActionType

ISAWHHistory::ActionType

Description

Returns the action type.

Syntax

string ObjectName.ActionType

See Also

  • ISAWHHistory Interface


ActionDescription

ISAWHHistory::ActionDescription

Description

Returns the description of the action.

Syntax

string ObjectName.ActionDescription

See Also

  • ISAWHHistory Interface


UserName

ISAWHHistory::UserName

Description

Returns the name of the user who made the change.

Syntax

string ObjectName.UserName

See Also

  • ISAWHHistory Interface


LabelName

ISAWHHistory::LabelName

Description

Returns the the name of the label, if any.

Syntax

string ObjectName.LabelName

See Also

  • ISAWHHistory Interface


Comment

ISAWHHistory::Comment

Description

Returns the comment of the action (if any).

Syntax

string ObjectName.Comment

See Also

  • ISAWHHistory Interface


IsPinned

ISAWHHistory::Is Pinned

Description

Returns whether the item is pinned.

Syntax

boolean ObjectName.IsPinned

See Also

  • ISAWHHistory Interface


ChangeSetIdLow

ISAWHHistory::ChangeSetIdLow

Description

Returns the low-order 32 bits of the change set ID.

Syntax

long ObjectName.ChangeSetIdLow

See Also

  • ISAWHHistory Interface


ItemName

ISAWHHistory::ItemName

Description

Returns the full name of the item.

Syntax

string ObjectName.ItemName

See Also

  • ISAWHHistory Interface


ChangeSetIdHigh

ISAWHHistory::ChangeSetId High

Description

Returns the high-order 32 bits of the change set ID.

Syntax

long ObjectName.ChangeSetIdHigh

See Also

  • ISAWHHistory Interface


HistoryIdHigh

ISAWHHistory::HistoryId High

Description

Returns the high-order 32 bits of the history record ID.

Syntax

long ObjectName.HistoryIdHigh

See Also

  • ISAWHHistory Interface


VersionNumberLow

ISAWHHistory::VersionNumberLow

Description

Returns the low-order 32 bits of the history item's version number.

Syntax

long ObjectName.VersionNumberLow

See Also

  • ISAWHHistory Interface


VersionNumberHigh

ISAWHHistory::VersionNumberHigh

Description

Returns the high-order 32 bits of the history item's version number.

Syntax

long ObjectName.VersionNumberHigh

See Also

  • ISAWHHistory Interface


FileSizeLow

ISAWHHistory::FileSizeLow

Description

Returns the low-order 32 bits of the file size.

Syntax

long ObjectName.FileSizeLow

See Also

  • ISAWHHistory Interface


FileSizeHigh

ISAWHHistory::FileSizeHigh

Description

Returns the high-order 32 bits of the file size.

Syntax

long ObjectName.FileSizeHigh

See Also

  • ISAWHHistory Interface


ItemIdLow

ISAWHHistory::ItemIdLow

Description

Returns the low-order 32 bits of the item ID.

Syntax

long ObjectName.ItemIdLow

See Also

  • ISAWHHistory Interface


ItemIdHigh

ISAWHHistory::ItemId High

Description

Returns the high-order 32 bits of the item ID.

Syntax

long ObjectName.ItemIdHigh

See Also

  • ISAWHHistory Interface


ISAWSHistorySet Interface

ISAWHHistorySet Interface

ISAWHHistorySet is the interface for managing ISAWHHistory objects.

The ISAWHHistorySet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHHistorySet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetProjectHistory GetFileHistory


GetCount

ISAWHHistorySet::Count

Description

Retrieves the number of the item's history records.

Syntax

long ObjectName.Count()

Parameters

No parameter.

Return Value

Returns the number of the item's history records.

See Also

  • ISAWHHistorySet Interface
  • ISAWHHistory Interface


Get

ISAWSHistorySet::Item

Description

Retrieves a piece of item's history record.

Syntax

VARIANT* ObjectName.Item(Long Index)

Parameters

Index
[in] Specifies the index number of the history record.

Return Value

Returns the history record of an item.

See Also

  • ISAWHHistorySet Interface
  • ISAWHHistory Interface


ISAWHHistorySet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* _NewEnum()

Parameters

No Parameter.

Return Value

Returns the collection to be iterated over.


ISAWSHistoryOrderBy Interface

ISAWHHistoryOrderBy Interface

ISAWHHistoryOrderBy is the interface for storing the history information of an item.

The ISAWHHistoryOrderBy interface exposes the following properties.

  • HistorySortBy
  • OrderAscending

ISAWHHistoryOrderBy interface is used for the following method.

Interface | Method
ISAWHFileHistoryParam | AddOrder
ISAWHProjectHistoryParam | AddOrder


HistorySortBy

ISAWH HistoryOrderBy::HistorySortBy

Description

Returns how to sort the history record.

Syntax

Enum_HistorySortBy ObjectName.HistorySortBy

See Also

  • ISAWHHistoryOrderBy I nterface


OrderAscending

ISAWHHistoryOrderBy::OrderAscending

Description

Returns whether the history record is sorted in ascending or descending order.

Syntax

b oolean ObjectName.OrderAscending

See Also

  • ISAWHHistoryOrderBy I nterface


ISAWSLabelFile Interface

ISAWHLabelFile Interface

ISAWHLabeledInfo is the interface for storing information about a labeled file.

The ISAWHLabeledInfo interface exposes the following properties.

  • LabelFileName
  • VersionNumberLow
  • VersionNumherHigh

ISAWHLabeledInfo interface is used for the following method.

Interface | Method
ISAWHLabelFileSet | Add


LabelFileName

ISAWHLabelFile::LabelFileName

Description

Returns the full name of the labeled file.

Syntax

string ObjectName.LabelFileName

See Also

  • ISAWHLabelFile Interface


VersionNumberLow

ISAWHLabelFile::VersionNumberLow

Description

Returns the low-order 32 bits of the labeled file's version number.

Syntax

long ObjectName.VersionNumberLow

See Also

  • ISAWHLabelFile Interface


VersionNumberHigh

ISAWHLabelFile::VersionNumberHigh

Description

Returns the high-order 32 bits of the labeled file's version number.

Syntax

long ObjectName.VersionNumberHigh

See Also

  • ISAWHLabelFile Interface


ISAWSLabelFileSet Interface

ISAWHLabelFileSet Interface

ISAWHLabelFileSet is the interface for managing ISAWHLabelFile objects.

The ISAWHLabelFileSet interface exposes the following method.

  • Add

ISAWHLabelFileSet interface is used for the following method.

Interface | Method
ISAWHAppObject | LabelFiles


Add

ISAWHLabelFileSet::Add

Description

Adds the file information which is stored in ISAWHLabelFile interface to ISAWHLabelFileSet.

Syntax

boolean ObjectName.Add(ISAWHLabelFile* LabelFile)

Parameters

LabelFile
[in] Specifies the name of the labeled file.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHLabelFileSet Interface
  • ISAWHLabelFile Interface


ISAWSLabeledInfo Interface

ISAWHLabeledInfo Interface

ISAWHLabeledInfo is the interface for storing a piece of label record.

The ISAWHLabeledInfo interface exposes the following properties.

  • LabelName
  • ModificationDateTime
  • CheckinDateTime
  • LabelDateTime
  • Mergeable
  • LabelRoot
  • ItemName
  • IsProject
  • IsPinned
  • LabelAt
  • UserName
  • Comment
  • LabelIdLow
  • LabelIdHigh
  • FileSizeLow
  • FileSizeHigh
  • HistoryIdLow
  • HistoryIdHigh
  • ItemIdLow
  • ItemIdHigh
  • VersionNumberLow
  • VersionNumherHigh

ISAWHLabeledInfo interface is used for the following method.

Interface | Method
ISAWHLabeledInfoSet | Count Item _NewEnum ¡¡


LabelName

ISAWHLabeledInfo::LabelName

Description

Returns the label name.

Syntax

string ObjectName.LabelName

See Also

  • ISAWHLabeledInfo Interface


ModificationDateTime

ISAWHLabeledInfo::ModificationDateTime

Description

Returns the modification date/time of the labeled item.

Syntax

DATE ObjectName.ModificationDateTime

See Also

  • ISAWHLabeledInfo Interface


CheckinDateTime

ISAWH LabeledInfo::CheckinDateTime

Description

Returns the check-in date/time of the labeled item.

Syntax

DATE ObjectName.CheckinDateTime

See Also

  • ISAWHLabeledInfo Interface


LabelDateTime

ISAWHLabeledInfo::LabelDateTime

Description

Returns the date/time of the label.

Syntax

DATE ObjectName.LabelDateTime

See Also

  • ISAWHLabeledInfo Interface


IsMergeable

ISAWHLabeledInfo::Mergeable

Description

Returns whether the item is mergeable.

Syntax

boolean ObjectName.Mergeable

See Also

  • ISAWHLabeledInfo Interface


LabelRoot

ISAWHLabeledInfo::LabelRoot

Description

Returns whether the project is the root project to which the label was applied.

Syntax

boolean ObjectName.LabelRoot

See Also

  • ISAWHLabeledInfo Interface


ItemName

ISAWHLabeledInfo::ItemName

Description

Returns the full name of the labeled item.

Syntax

string ObjectName.ItemName

See Also

  • ISAWHLabeledInfo Interface


IsProject

ISAWHLabeledInfo::IsProject

Description

Returns whether the labeled item is a project.

Syntax

boolean ObjectName.IsProject

See Also

  • ISAWHLabeledInfo Interface


IsPinned

ISAWHLabeledInfo::Is Pinned

Description

Returns whether the labeled item is pinned.

Syntax

boolean ObjectName.IsPinned

See Also

  • ISAWHLabeledInfo Interface


LabelAt

ISAWHLabeledInfo::LabelAt

Description

Returns the information of the item at which the label was created.

Syntax

string ObjectName.LabelAt

See Also

  • ISAWHLabeledInfo Interface


UserName

ISAWHLabeledInfo::UserName

Description

Returns the name of the user who adds the label.

Syntax

string ObjectName.UserName

See Also

  • ISAWHLabeledInfo Interface


Comment

ISAWHLabeledInfo::Comment

Description

Returns the comment of the label (if any).

Syntax

string ObjectName.Comment

See Also

  • ISAWHLabeledInfo Interface


LabelIdLow

ISAWHLabeledInfo::LabelIdLow

Description

Returns the low-order 32 bits of label ID.

Syntax

long ObjectName.LabelIdLow

See Also

  • ISAWHLabeledInfo Interface


LabelIdHigh

ISAWH LabeledInfo::LabelIdHigh

Description

Returns the high-order 32 bits of the label ID.

Syntax

long ObjectName.LabelIdHigh

See Also

  • ISAWHLabeledInfo Interface


FileSizeLow

ISAWHLabeledInfo::FileSizeLow

Description

Returns the low-order 32 bits of the labeled file size.

Syntax

long ObjectName.FileSizeLow

See Also

  • ISAWHLabeledInfo Interface


FileSizeHigh

ISAWHLabeledInfo::FileSizeHigh

Description

Returns the high-order 32 bits of the labeled file size.

Syntax

long ObjectName.FileSizeHigh

See Also

  • ISAWHLabeledInfo Interface


HistoryIdLow

ISAWHLabeledInfo::HistoryId Low

Description

Returns the low-order 32 bits of the history record ID.

Syntax

long ObjectName.HistoryId Low

See Also

  • ISAWHLabeledInfo Interface


HistoryIdHigh

ISAWHLabeledInfo::HistoryId High

Description

Returns the high-order 32 bits of the history record ID.

Syntax

long ObjectName.HistoryIdHigh

See Also

  • ISAWHLabeledInfo Interface


ItemIdLow

ISAWHLabeledInfo::ItemIdLow

Description

Returns the low-order 32 bits of the labeled item ID.

Syntax

long ObjectName.ItemIdLow

See Also

  • ISAWHLabeledInfo Interface


ItemIdHigh

ISAWHLabeledInfo::ItemId High

Description

Returns the high-order 32 bits of the item ID.

Syntax

long ObjectName.ItemIdHigh

See Also

  • ISAWHLabeledInfo Interface


VersionNumberLow

ISAWHLabeledInfo::VersionNumberLow

Description

Returns the low-order 32 bits of the labeled item's version number.

Syntax

long ObjectName.VersionNumberLow

See Also

  • ISAWHLabeledInfo Interface


VersionNumberHigh

ISAWHLabeledInfo::VersionNumberHigh

Description

Returns the high-order 32 bits of the labeled item's version number.

Syntax

long ObjectName.VersionNumberHigh

See Also

  • ISAWHLabeledInfo Interface


ISAWSLabeledInfoSet Interface

ISAWHLabeledInfoSet Interface

ISAWHLabeledInfoSet is the interface for managing the ISAWHLabeledInfo objects.

The ISAWHLabeledInfoSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHLabeledInfoSet interface is used for the following methods.

Interface | Method
ISAWHAppObject | GetProjectLabeledInfo GetFileLabeledInfo


GetCount

ISAWHLabeledInfoSet::Count

Description

Returns the number of labeled item.

Syntax

long ObjectName.Count()

Parameters

No parameter.

Return Value

Returns the number of labels.

See Also

  • ISAWHLabeledInfoSet Interface
  • ISAWHLabeledInfo Interface


ISAWHLabeledInfoSet::Item

Description

Retrieves a piece of label record.

Syntax

VARIANT* Item(long Index)

Parameters

Index
[in] Specifies the index number of the labeled item.

Return Value

Returns a piece of label record.

See Also

  • ISAWHLabeledInfoSet Interface
  • ISAWHLabeledInfo Interface


ISAWHLabeledInfoSet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* _NewEnum()

Parameters

No Parameter.

Return Value

Returns the collection to be iterated over.


ISAWSLatestFile Interface

ISAWHLatestFile Interface

ISAWHLatestFile is the interface for storing the filename information when retrieving the latest file from the server.

The ISAWHLatestFile interface exposes the following properties.

  • FileToGet
  • LocalFileName

ISAWHLatestFile interface is used for the following method.

Interface | Method
ISAWHLatestFileSet | Add


FileToGet

ISAWHLatestFile::FileToGet

Description

Sets the full name of the server file to be retrieved.

Syntax

string ObjectName.FileToGet

See Also

  • ISAWHLatestFile Interface


LocalFileName

ISAWHLatestFile::LocalFileName

Description

Sets the path name of the local file copy.

Syntax

string ObjectName.LocalFileName

See Also

  • ISAWHLatestFile Interface


ISAWSLatestFileSet Interface

ISAWHLatestFileSet Interface

ISAWHLatestFileSet is the interface for managing ISAWHLatestFile objects.

The ISAWHLatestFileSet interface exposes the following method.

  • Add

ISAWHLatestFileSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetLatestFiles


Add

ISAWHLatestFileSet::Add

Description

Adds the name of a file which is stored in ISAWHLatestFile interface to the name set ISAWHLatestFileSet.

Syntax

Boolean ObjectName.Add(ISAWHLatestFile* LatestFile)

Parameters

LatestFile
[in] Specifies the name of the file to be got.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHLatestFileSet Interface
  • ISAWHLatestFile Interface


ISAWSLatestProject Interface

ISAWHLatestProject Interface

ISAWHLatestProject is the interface for storing the name information when retrieving the latest project from the server.

The ISAWHLatestProject interface exposes the following properties.

  • ProjectToGet
  • LocalFolder

ISAWHLatestProject interface is used for the following method.

Interface | Method
ISAWHLatestProjectSet | Add


ProjectToGet

ISAWHLatestProject::ProjectToGet

Description

Sets the full name of the project to be retrieved.

Syntax

string ObjectName.ProjectToGet

See Also

  • ISAWHLatestProject Interface


LocalFolder

ISAWHLatestProject::LocalFolder

Description

Sets the path name of the local directory of the project.

Syntax

string ObjectName.LocalFolder

See Also

  • ISAWHLatestProject Interface


ISAWSLatestProjectSet Interface

ISAWHLatestProjectSet Interface

ISAWHLatestProjectSet is the interface for managing ISAWHLatestProject objects.

The ISAWHLatestProjectSet interface exposes the following methods.

  • Add

ISAWHLatestProjectSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetLatestProjects


Add

ISAWHLatestProjectSet::Add

Description

Adds the name information of a project which is stored in ISAWHLatestProject interface to ISAWHLatestProjectSet.

Syntax

boolean ObjectName.Add(ISAWHLatestProject* LatestProject)

Parameters

LatestProject
[in] Specifies the name of the project to be got.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHLatestProjectSet Interface
  • ISAWHLatestProject Interface


ISAWSWebProject Interface

ISAWHLoginInfo Interface

ISAWHLoginInfo is the interface for storing the information about a login record.

The ISAWHLoginInfo interface exposes the following properties.

  • LoginIP

  • LoginDNS

  • LoginResult

  • LoginTime

  • ClientType

ISAWHLoginInfo interface is used for the following method.

Interface | Method
ISAWHLoginInfoSet | Get


DeployName

ISAWHLoginInfo::LoginTime

Description

Specifies when the login happened.

Syntax

string ObjectName.LoginTime

See Also

  • ISAWHLoginInfo Interface


EnumEOL

Enum_EOL Enum

Description

Indicates which EOL (End of Line) is used.

It is used with the following methods.

Interface Method
ISAWHAppObject CheckInFiles()
CheckInProject()
CheckoutFiles()
CheckoutProject()
GetLatestFiles()
GetLatestProject()
GetLatestProjects()
GetOldVersionFile()
IsFileSameAsOnServer()
UndoCheckoutFiles()
UndoCheckoutProject()
WebDeploy()

Constants
Name | Value | Description
Enum_EOLNative | 0 | Keeps the original EOL terminator(s).
Enum_EOLWindowsCRLF | 1 | EOL= '\n' + '\r'
Enum_EOLUnixCR | 2 | EOL= '\n'
Enum_EOLMacLF | 3 | EOL= '\r'


ItemName

ISAWHLoginInfo::LoginIP

Description

Specifies the IP address of the machine where the login happened.

Syntax

string ObjectName.LoginIP

See Also

  • ISAWHLoginInfo Interface


DeployName

ISAWHLoginInfo::LoginDNS

Description

Specifies the DNS of the machine where the login happened.

Syntax

string ObjectName.LoginDNS

See Also

  • ISAWHLoginInfo Interface


DeployName

ISAWHLoginInfo::ClientType

Description

Specifies the client type that is used to login.

Syntax

string ObjectName.ClientType

See Also

  • ISAWHLoginInfo Interface
  • Enum_ClientType Enumeration


ISAWSWebProjectSet Interface

ISAWHLoginInfoSet Interface

ISAWHLoginInfoSet is the interface for managing ISAWHLoginInfo objects.

The ISAWHLoginInfoSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHLoginInfoSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetLoginInfos


GetCount

ISAWHLoginInfoSet::Count

Description

Returns the number of login records.

Syntax

long ObjectName.Count()

Parameters

No Parameter.

Return Value

Returns the number of login records.

See Also

  • ISAWHLoginInfoSet Interface
  • ISAWHLoginInfo Interface


Get

ISAWHLoginInfoSet::Item

Description

Retrieves the information about a login record.

Syntax

BSTR* Item (long Index)

Parameters

Index
[in] Specifies the index number of the login record.

Return Value

Return the information about a login record.

See Also

  • ISAWHLoginInfoSet Interface
  • ISAWHLoginInfo Interface


ISAWHLoginInfoSet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* _NewEnum()

Parameters

No Parameter.

Return Value

Returns the collection to be iterated over.


ISAWSMoveFileSet Interface

ISAWHMoveFileSet Interface

ISAWHMoveFileSet is the interface for storing the name set of to-be-moved files.

The ISAWHMoveFileSet interface exposes the following method.

  • Add

ISAWHMoveFileSet interface is used for the following method..

Interface | Method
ISAWHAppObject | MoveFiles


Add

ISAWHMoveFileSet::Add

Description

Adds the name of a to-be-moved file to ISAWHMoveFileSet.

Syntax

boolean ObjectName.Add(BSTR FileName)

Parameters

FileName
[in] Specifies the name of the file to be moved.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHMoveFileSet Interface


ISAWSOperationResult Interface

ISAWHOperationResult Interface

ISAWHOperationResult is the interface for storing the result information of an item in an operation.

For example, when adding two files "test1.txt" and "test2.txt" to "D:\project\" project, the result information is as follows (if the operation succeeds):

Adding D:\project\test1.txt to server : Completed
Adding D:\project\test2.txt to server : Completed

In this example, adding two files to server produces two operation result messages. Each one is stored in an ISAWHOperationResult object that is managed by an ISAWHOperationResultSet object.

The ISAWHOperationResult interface exposes the following properties.

  • Description
  • OperationResult
  • ItemName
  • ItemIdLow
  • ItemIdHigh
  • IsFile

ISAWHOperationResult interface is used for the following method.

Interface | Method
ISAWHOperationResultSet | Count Item _NewEnum ¡¡


Description

ISAWHOperationResult::Description

Description

Returns the description of the operation result.

Syntax

string ObjectName.Description

See Also

  • ISAWHOperationResult Interface


OperationResult

ISAWHOperationResult::OperationResult

Description

Returns the result of an operation.

Syntax

long ObjectName.OperationResult

See Also

  • ISAWHOperationResult Interface


ItemName

ISAWHOperationResult::ItemName

Description

Returns the full name of the item on which the operation is performed.

Syntax

string ObjectName.ItemName

See Also

  • ISAWHOperationResult Interface


ItemIdLow

ISAWHOperationResult::ItemIdLow

Description

Returns the low-order 32-bit ID of the item on which the operation is performed.

Syntax

long ObjectName.ItemIdLow

See Also

  • ISAWHOperationResult Interface


ItemIdHigh

ISAWHOperationResult::ItemIdHigh

Description

Returns the high-order 32-bit ID of the item on which the operation is performed.

Syntax

long ObjectName.ItemIdHigh

See Also

  • ISAWHOperationResult Interface


IsFile

ISAWHOperationResult::IsFile

Description

Returns whether the item on which the operation is performed is a file.

Syntax

boolean ObjectName.IsFile

See Also

  • ISAWHOperationResult Interface


ISAWSOperationResultSet Interface

ISAWHOperationResultSet Interface

ISAWHOperationResultSet is the interface for managing ISAWHOperationResult objects.

The ISAWHOperationResultSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHOperationResultSet interface is used for the following method.

Interface | Method
ISAWHAppObject | All methods


GetCount

ISAWHOperationResultSet::GetCount

Description

Returns the piece number of operation result.

Syntax

long ObjectName.GetCount()

Parameters

No parameter.

Return Value

Returns the piece number of operation result.

See Also

  • ISAWHOperationResultSet Interface
  • ISAWHOperationResult Interface


ISAWHOperationResultSet::Item

Description

Retrieves the result information of an operation.

Syntax

VARIANT* ObjectName.Item(Long Index)

Parameters

Index
[in] Specifies the index number of the result.

Return Value

Returns the result information of an operation.

See Also

  • ISAWHOperationResultSet Interface
  • ISAWHOperationResult Interface


ISAWSOperationResultSend Interface

ISAWHOperationResultSend Interface

ISAWHOperationResultSend is the interface for storing the process information of an operation.

The ISAWHOperationResultSend interface exposes the following properties.

  • Description
  • Successful

ISAWHOperationResult interface is used for the following method.

Interface | Method
ISAWHOperationResultSendSet | Get


Successful

ISAWHOperationResultSend::Successful

Description

Returns whether each step of the operation procedure is successful.

Syntax

long ObjectName.Successful

See Also

  • ISAWHOperationResultSend Interface


Description

ISAWHOperationResultSend::Description

Description

Returns the result information about each step of the operation procedure.

Syntax

string ObjectName.Description

See Also

  • ISAWHOperationResultSend Interface


ISAWSOperationResultSendSet Interface

ISAWHOperationResultSendSet Interface

ISAWHOperationResultSendSet is the interface for managing ISAWHOperationResultSend objects.

The ISAWHOperationResultSendSet interface exposes the following methods.

  • GetCount
  • Get

ISAWHOperationResultSendSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetOperationResultSend


GetCount

ISAWHOperationResultSendSet::GetCount

Description

Returns the piece number of operation procedure information.

Syntax

long ObjectName.GetCount()

Parameters

No parameter.

Return Value

Returns the piece number of operation procedure information.

See Also

  • ISAWHOperationResultSendSet Interface
  • ISAWHOperationResultSend Interface


Get

ISAWHOperationResultSet::Get

Description

Retrieves the result information about each step of the operation procedure.

Syntax

boolean ObjectName.Get(Long Index, ISAWHOperationResultSend* OperationResultSend)

Parameters

Index
[in] Specifies the index number of the result information.

OperationResultSend
[in] Specifies the result information about each step of the operation procedure.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHOperationResultSendSet Interface
  • ISAWHOperationResultSend Interface


ISAWSProjectHistoryParam Interface

ISAWHProjectHistoryParam Interface

ISAWHProjectHistoryParam is the interface for storing parameters used to filter the project history record.

The ISAWHProjectHistoryParam interface exposes the following methods and properties.

  • AddUser
  • AddFileExtension
  • AddFileSubString
  • IsRecursive
  • IsIncludedAnyComment
  • CommentSubString
  • AddOrder
  • DateFrom
  • DateTo
  • SetActionType

ISAWHProjectHistoryParam interface is used for the following method.

Interface | Method
ISAWHAppObject | GetProjectHistory


AddUser

ISAWHProjectHistoryParam::AddUser

Description

Filters the history record by user.

Syntax

boolean ObjectName.AddUser(BSTR UserName)

Parameter

UserName
[in] Specifies the user name.

See Also

  • ISAWHProjectHistoryParam Interface


AddFileExtension

ISAWHProjectHistoryParam::AddFileExtension

Description

Restricts the history report to the files with the specified extensions.

Syntax

boolean ObjectName.AddFileExtension(BSTR FileExtension)

Parameter

FileExtension
[in] Specifies the file extension.

See Also

  • ISAWHProjectHistoryParam Interface


AddFileSubString

ISAWHProjectHistoryParam::AddFileSubString

Description

Restricts the history report to the files whose names match the input substring.

Syntax

boolean ObjectName.AddFileSubString(BSTR FileSubString)

Parameter

FileSubString
[in] Specifies the file name substring.

See Also

  • ISAWHProjectHistoryParam Interface


IsRecursive

ISAWHProjectHistoryParam::IsRecursive

Description

Specifies whether to show the history information of the project and all its descendants.

Syntax

boolean ObjectName.IsRecursive

See Also

  • ISAWHProjectHistoryParam Interface


IsIncludedAnyComment

ISAWHProjectHistoryParam::IsIncludedAnyComment

Description

Specifies whether to filter the history record by comments.

Syntax

boolean ObjectName.IsIncludedAnyComment

See Also

  • ISAWHProjectHistoryParam Interface


CommentSubstring

ISAWHProjectHistoryParam::CommentSubstring

Description

Filters the project history by the comments that match the substring.

Syntax

boolean ObjectName.CommnetSubstring

See Also

  • ISAWHProjectHistoryParam Interface


AddOrder

ISAWHProjectHistoryParam::AddOrder

Description

Sorts the history by the specific item.

Syntax

boolean ObjectName.AddOrder(ISAWHHistoryOrderBy* HistoryOrderBy)

Parameter

HistoryOrderBy
[in] Specifies the item used to sort the history record.

See Also

  • ISAWHProjectHistoryParam Interface
  • ISAWHHistoryOrderBy Interface


DateFrom

ISAWHProjectHistoryParam::DateFrom

Description

Restricts the history report to begin at the date specified.

Syntax

Date ObjectName.DateFrom

See Also

  • ISAWHProjectHistoryParam Interface


DateTo

ISAWHProjectHistoryParam::DateTo

Description

Restricts the history report to end at the date specified.

Syntax

Date ObjectName.DateTo

See Also

  • ISAWHProjectHistoryParam Interface


SetActionType

ISAWHProjectHistoryParam::SetActionType

Description

Restricts the history report to the selected actions.

Syntax

HRESULT ObjectName.SetActionType(ISAWHActionType* ActionType);

Parameter

ActionType
[in] Specifies the action type, such as Add, Delete, Check In and others.

See Also

  • ISAWHProjectHistoryParam Interface
  • ISAWHActionType Interface


ISAWSProjectListSet Interface

ISAWHProjectListSet Interface

ISAWHProjectListSet is the interface for storing the name set of all subprojects in a project.

The ISAWHProjectListSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHProjectListSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetProjectListFromProject


GetCount

ISAWHProjectListSet::Count

Description

Returns the number of subprojects in the project.

Syntax

long ObjectName.Count()

Parameters

No parameter.

Return Value

Returns the number of subprojects in the project.

See Also

  • ISAWHProjectListSet Interface


ISAWHProjectListSet::Item

Description

Retrieves the subproject name.

Syntax

BSTR* Item (long Index)

Parameters

Index
[in] Specifies the index number of the file.

Return Value

Return the subproject name.

See Also

  • ISAWHProjectListSet Interface


ISAWHProjectListSet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* _NewEnum()

Parameters

No Parameter.

Return Value

Returns the collection to be iterated over.


ISAWSPurgeItem Interface

ISAWHPurgeItem Interface

ISAWHPurgeItem is the interface for storing the general information about a to-be-purged deleted item.

The ISAWHPurgeItem interface exposes the following properties.

  • ItemName
  • Description
  • IsProject
  • Successful

ISAWHPurgeItem interface is used for the following method.

Interface | Method
ISAWHPurgeItemSet | Get


ItemName

ISAWHPurgeItem::ItemName

Description

Returns the full name of a to-be-purged deleted item.

Syntax

string ObjectName.ItemName

See Also

  • ISAWHPurgeItem Interface


Successful

ISAWHPurgeItem::Successful

Description

Returns whether the deleted item is successfully purged.

Syntax

string ObjectName.Successful

See Also

  • ISAWHPurgeItem Interface


Description

ISAWHPurgeItem::Description

Description

Returns the description of the to-be-purged deleted item.

Syntax

string ObjectName.Description

See Also

  • ISAWHPurgeItem Interface


IsProject

ISAWHPurgeItem::IsProject

Description

Returns whether the to-be-purged deleted item is a project.

Syntax

boolean ObjectName.IsProject

See Also

  • ISAWHPurgeItem Interface


ISAWSPurgeItemSet Interface

ISAWHPurgeItemSet Interface

ISAWHPurgeItemSet is the interface for managing ISAWHPurgeItem objects.

The ISAWHPurgeItemSet interface exposes the following methods.

  • GetCount
  • Get
  • Add

ISAWHPurgeItemSet interface is used for the following method.

Interface | Method
ISAWHAppObject | PurgeItems


GetCount

ISAWHPurgeItemSet::GetCount

Description

Returns the number of to-be-purged items.

Syntax

long ObjectName.GetCount()

Parameters

No Parameter.

Return Value

Returns the number of to-be-purged items.

See Also

  • ISAWHPurgeItemSet Interface
  • ISAWHPurgeItem Interface


Get

ISAWHPurgeItemSet::Get

Description

Retrieves the information of a to-be-purged item.

Syntax

boolean Get(long Index, ISAWHPurgeItem* PurgeItem)

Parameters

Index
[in] Specifies the index number of the purged item.

PurgeItem
[in] Specifies the general information about the purged item.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHPurgeItemSet Interface
  • ISAWHPurgeItem Interface


Add

ISAWHPurgeItemSet::Add

Description

Adds the general information about a to-be-purged deleted item to ISAWPurgeItemSet.

Syntax

boolean Add(ISAWHPurgeItem* PurgeItem)

Parameters

PurgeItem
[in] Specifies the name of the deleted item to be purged.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHPurgeItemSet Interface
  • ISAWHPurgeItem Interface


ISAWSRecoverItem Interface

ISAWHRecoverItem Interface

ISAWHRecoverItem is the interface for storing the general information about a to-be-recovered deleted item.

The ISAWHRecoverItem interface exposes the following property.

  • ItemName
  • CheckinDateTime
  • CheckoutUser
  • Description
  • FileSizeHigh
  • FileSizeLow
  • IsProject
  • ItemStatus
  • ModificationDateTime
  • Successful
  • VersionNumberHigh
  • VersionNumberLow

ISAWHPurgeItemSet interface is used for the following method.

Interface | Method
ISAWHRecoverItemSet | Get


ItemName

ISAWHRecoverItem::ItemName

Description

Returns the full name of a to-be-recovered deleted item.

Syntax

string ObjectName.ItemName

See Also

  • ISAWHRecoverItem Interface


IsProject

ISAWHRecoverItem::IsProject

Description

Returns whether the to-be-recovered deleted item is a project.

Syntax

boolean ObjectName.IsProject

See Also

  • ISAWHRecoverItem Interface


ModificationDateTime

ISAWHRecoverItem::ModificationDateTime

Description

Returns the modification date/time of the to-be-recovered deleted item.

Syntax

DATE ObjectName.ModificationDateTime

See Also

  • ISAWHRecoverItem Interface


CheckinDateTime

ISAWH RecoverItem::CheckinDateTime

Description

Returns the check-in date/time of the to-be-recovered deleted item.

Syntax

DATE ObjectName.CheckinDateTime

See Also

  • ISAWHRecoverItem Interface


ItemStatus

ISAWHRecoverItem::ItemStatus

Description

Returns the status of a to-be-recovered deleted item.

Syntax

Enum_ItemStatus ObjectName.ItemStatus

See Also

  • ISAWHRecoverItem Interface


CheckoutUser

ISAWHRecoverItem::CheckoutUser

Description

Returns the name of the user who has the to-be-recovered item checked out.

Syntax

string ObjectName.CheckoutUser

See Also

  • ISAWHRecoverItem Interface


Successful

ISAWHRecoverItem::Successful

Description

Returns whether the item is successfully recovered.

Syntax

string ObjectName.Successful

See Also

  • ISAWHRecoverItem Interface


Description

ISAWHRecoverItem::Description

Description

Returns the description of the to-be-recovered deleted item.

Syntax

string ObjectName.Description

See Also

  • ISAWHRecoverItem Interface


FileSizeLow

ISAWHRecoverItem::FileSizeLow

Description

Returns the low-order 32 bits the to-be-recovered deleted item's size.

Syntax

long ObjectName.FileSizeLow

See Also

  • ISAWHRecoverItem Interface


FileSizeHigh

ISAWHRecoverItem::FileSizeHigh

Description

Returns the high-order 32 bits of the to-be-recovered deleted item's size.

Syntax

long ObjectName.FileSizeHigh

See Also

  • ISAWHRecoverItem Interface


VersionNumberLow

ISAWHRecoverItem::VersionNumberLow

Description

Returns the low-order 32 bits of the to-be-recovered deleted item's version number.

Syntax

long ObjectName.VersionNumberLow

See Also

  • ISAWHRecoverItem Interface


VersionNumberHigh

ISAWHRecoverItem::VersionNumberHigh

Description

Returns the high-order 32 bits of the to-be-recovered deleted item's version number.

Syntax

long ObjectName.VersionNumberHigh

See Also

  • ISAWHRecoverItem Interface


ISAWSRecoverItemSet Interface

ISAWHRecoverItemSet Interface

ISAWHRecoverItemSet is the interface for managing ISAWHRecoverItem objects.

The ISAWHRecoverItemSet interface exposes the following methods.

  • GetCount
  • Get
  • Add

ISAWHRecoverItemSet interface is used for the following method.

Interface | Method
ISAWHAppObject | RecoverItems


GetCount

ISAWHRecoverItemSet::GetCount

Description

Returns the number of to-be-recovered items.

Syntax

long ObjectName.GetCount()

Parameters

No Parameter.

Return Value

Returns the number of to-be-recovered items.

See Also

  • ISAWHRecoverItemSet Interface
  • ISAWHRecoverItem Interface


Get

ISAWHRecoverItemSet::Get

Description

Retrieves the information of a to-be-recovered item.

Syntax

boolean Get(long Index, ISAWHRecoverItem* RecoverItem)

Parameters

Index
[in] Specifies the index number of the to-be-recovered item.

RecoverItem
[in] Specifies the general information about the to-be-recovered item.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHRecoverItemSet Interface
  • ISAWHRecoverItem Interface


Add

ISAWHRecoverItemSet::Add

Description

Adds the general information about a to-be-recovered deleted item to ISAWHRecoverItemSet.

Syntax

boolean ObjectName.Add(ISAWHRecoverItem* RecoverItem)

Parameters

RecoverItem
[in] Specifies the name of the deleted item to be recovered.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHRecoverItemSet Interface
  • ISAWHRecoverItem


ISAWSRepositoryInfo Interface

ISAWHRepositoryInfo Interface

ISAWHRepositoryInfo is the interface for storing the property information about a repository.

The ISAWHRepositoryInfo interface exposes the following properties.

  • RepositoryName

  • RepositoryId

  • Description

  • IsAllowMultiCheckout

  • IsCommentRequiredForCheckin

  • IsCheckoutRequiredBeforeCheckin

  • IsEnableFolderSecurity

  • IsStoreLatestVersionInZipFormat

ISAWHRepositoryInfo interface is used for the following methodS.

Interface | Method
ISAWHRepositoryInfoSet | Count Item _NewEnum ¡¡


RepositoryName

ISAWHRepositoryInfo::RepositoryName

Description

Returns the repository name.

Syntax

string ObjectName.RepositoryName

See Also

  • ISAWHRepositoryInfo Interface


RepositoryId

ISAWHRepositoryInfo::RepositoryId

Description

Returns the ID number of the repository.

Syntax

long ObjectName.RepositoryId

See Also

  • ISAWHRepositoryInfo Interface


Description

ISAWHRepositoryInfo::Description

Description

Returns the description of the repository.

Syntax

string ObjectName.Description

See Also

  • ISAWHRepositoryInfo Interface


IsAllowMultiCheckout

ISAWHRepositoryInfo::IsAllowMultiCheckout

Description

Returns whether allowing multiple people to check out one file simultaneously in the repository.

Syntax

boolean ObjectName.IsAllowMultiCheckout

See Also

  • ISAWHRepositoryInfo Interface


IsCommentRequiredForCheckin

ISAWHRepositoryInfo::IsCommentRequiredForCheckin

Description

Returns whether comment is required for check-in in the repository.

Syntax

boolean ObjectName.IsCommentRequiredForCheckin

See Also

  • ISAWHRepositoryInfo Interface


IsCheckoutRequiredBeforeCheckin

ISAWHRepositoryInfo::IsCheckoutRequiredBeforeCheckin

Description

Returns whether allowing to check in an unchecked-out item in the repository.

Syntax

boolean ObjectName.IsCheckoutRequiredBeforeCheckin

See Also

  • ISAWHRepositoryInfo Interface


IsEnableFolderSecur

ISAWHRepositoryInfo::IsEnableFolderSecurity

Description

Returns whether the project security for individual user and project is enabled for the repository.

Syntax

boolean ObjectName.IsEnableFolderSecurity

See Also

  • ISAWHRepositoryInfo Interface


IsStoreLatestVersionInZipFormat

ISAWHRepositoryInfo::IsStoreLatestVersioInZipFormat

Description

Returns whether storing data in zip format in the repository .

Syntax

boolean ObjectName.IsStoreLatestVersionInZipFormat

See Also

  • ISAWHRepositoryInfo Interface


ISAWSRepositoryInfoSet Interface

ISAWHRepositoryInfoSet Interface

ISAWHRepositoryInfoSet is the interface for managing ISAWHRepositoryInfo objects.

The ISAWHRepositoryInfoSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHRepositoryInfoSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetAllRepositories


GetCount

ISAWHRepositorySet::Count

Description

Returns the number of Dynamsoft SourceAnywhere Hosted repositories.

Syntax

Long ObjectName.GetCount()

Parameters

No parameter.

Return Value

Returns the number of Dynamsoft SourceAnywhere Hosted repositories.

See Also

  • ISAWHRepositoryInfoSet Interface
  • ISAWHRepositoryInfo Interface


ISAWHRepositoryInfoSet::Item

Description

Retrieves the property information about a repository.

Syntax

VARIANT* ObjectName.Item(long Index);

Parameters

Index
[in] Specifies the index number of the repository.

Return Value

Returns the property information about a repository.

See Also

  • ISAWHRepositoryInfoSet Interface
  • ISAWHRepositoryInfo Interface


ISAWSRight Interface

ISAWHRight Interface

ISAWHRight is the interface for storing the current user's rights to the item.

The ISAWHRight interface exposes the following method.

  • HasRightOf

ISAWHRight interface is used for the following method.

Interface | Method
ISAWHAppObject | GetFileRight GetProjectRight


HasRightOf

ISAWHRight::HasRightOf

Description

Retrieves one piece of the current user's rights to the item.

Syntax

boolean HasRightOf(Enum_UserRight UserRight)

Parameters

UserRight
[in] Specifies one piece of the current user's rights to the item.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHRight Interface
  • Enum_UserRight Interface


ISAWSShareFileSet Interface

ISAWHShareFileSet Interface

ISAWHShareFileSet is the interface for storing the name set of to-be-shared files.

The ISAWHShareFileSet interface exposes the following method.

  • Add

ISAWHShareFileSet interface is used for the following method.

Interface | Method
ISAWHAppObject | ShareFiles


Add

ISAWHShareFileSet::Add

Description

Adds the full name of a to-be-shared file to ISAWHShareFileSet.

Syntax

boolean ObjectName.Add(BSTR ShareFile)

Parameters

ShareFile
[in] Specifies the full name of the file to be shared.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHShareFileSet Interface


ISAWSShareLink Interface

ISAWHShareLink Interface

ISAWHShareLink is the interface for storing the share link of a file.

The ISAWHShareLink interface exposes the following properties.

  • FileName
  • IsDeleted

ISAWHShareLink interface is used for the following method.

Interface | Method
ISAWHShareLinkSet | Count Item _NewEnum ¡¡


IsDeleted

ISAWHShareLink::IsDeleted

Description

Returns whether the share link is deleted.

Syntax

boolean ObjectName.IsDeleted

See Also

  • ISAWHShareLink Interface


FileName

ISAWHShareLink::FileName

Description

Returns name of the file's share link.

Syntax

string ObjectName.FileName

See Also

  • ISAWHShareLink Interface


ISAWSShareLinkSet Interface

ISAWHShareLinkSet Interface

ISAWHShareLinkSet is the interface for managing ISAWHShareLink objects.

The ISAWHShareLinkSet interface exposes the following methods.

  • Count
  • Item
  • _NewEnum

ISAWHShareLinkSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetFileShareLinks


ISAWHShareLinkSet::Count

Description

Returns the number of share links of the file.

Syntax

long ObjectName.Count()

Parameters

No parameter.

Return Value

Returns the number of share links of the file.

See Also

  • ISAWHShareLinkSet Interface
  • ISAWHShareLink Interface


Get

ISAWSShareLinkSet::Item

Description

Retrieves a share link of the file.

Syntax

VARIANT* ObjectName.Item(long Index)

Parameters

Index
[in] Specifies the index number of the share link.

Return Value

Returns a share link of the file.

See Also

  • ISAWHShareLinkSet Interface
  • ISAWHShareLink Interface


ISAWHShareLinkSet::_NewEnum

Description

Returns the collection to be iterated over.

Syntax

LPUNKNOWN* _NewEnum()

Parameters

No Parameter.

Return Value

Returns the collection to be iterated over.


ISAWSUndoCheckoutFile Interface

ISAWHUndoCheckoutFile Interface

ISAWHUndoCheckoutFile is the interface for storing information about a file that is to be undone checkout.

The ISAWHUndoCheckoutFile interface exposes the following properties.

  • FileToUndo
  • LocalFileName

ISAWHUndoCheckoutFile interface is used for the following method.

Interface | Method
ISAWHUndoCheckoutFileSet | Add


FileToUndo

ISAWHUndoCheckoutFile::FileToUndo

Description

Sets the full name of the server file to be undone check out.

Syntax

string ObjectName.FileToUndo

See Also

  • ISAWHUndoCheckoutFile Interface


LocalFileName

ISAWHUndoCheckoutFile::LocalFileName

Description

Specifies the path name of the local file copy.

Syntax

string ObjectName.LocalFileName

See Also

  • ISAWHUndoCheckoutFile Interface


ISAWSUndoCheckoutFileSet Interface

ISAWHUndoCheckoutFileSet Interface

ISAWHUndoCheckoutFileSet is the interface for managing ISAWHUndoCheckoutFile objects.

The ISAWHUndoCheckoutFileSet interface exposes the following method.

  • Add

ISAWHUndoCheckoutFileSet interface is used for the following method.

Interface | Method
ISAWHAppObject | UndoCheckoutFiles


Add

ISAWHUndoCheckoutFileSet::Add

Description

Adds the information of a to-be-undone-checked-out file which is stored in ISAWHUndoCheckoutFile interface to ISAWHUndoCheckoutFileSet.

Syntax

boolean ObjectName.Add(ISAWHUndoCheckoutFile* UndoCheckout)

Parameters

UndoCheckout
[in] Specifies information about a file to be undone checkout.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHUndoCheckoutFileSet Interface
  • ISAWHUndoCheckoutFile Interface


ISAWSUserSet Interface

ISAWHUserSet Interface

ISAWHUserSet the interface for storing the name set of all users in Dynamsoft SourceAnywhere Hosted.

The ISAWHUserSet interface exposes the following methods.

  • GetCount
  • Get

ISAWHUserSet interface is used for the following method.

Interface | Method
ISAWHAppObject | GetAllUsers


GetCount

ISAWHUserSet::GetCount

Description

Returns the number of users.

Syntax

long ObjectName.GetCount()

Parameters

No parameter.

Return Value

Returns the number of users.

See Also

  • ISAWHUserSet Interface


Get

ISAWHUserSet::Get

Description

Retrieves the user name.

Syntax

boolean ObjectName.Get(long Index, BSTR* UserName)

Parameters

Index
[in] Specifies the index number of the user.

UserName
[out] Returns the user name.

Return Value

TRUE indicates success. FALSE indicates failure.

See Also

  • ISAWHUserSet Interface


Events

The following topics describe the events for Dynamsoft SourceAnywhere Hosted SDK.

  • OnPercentDone Event
  • OnSendStatusMessage Event
  • PromptCheckinUnchangedFile Event
  • PromptLeaveOrReplaceWritableFile Event
  • PromptUndoCheckoutChangedFile Event


PromptCheckinUnchangedFile

PromptCheckinUnchangedFile Event

Description

Fired when checking in an unchanged file.

Syntax

HRESULT ObjectName_PromptCheckinUnchangedFile()

Remarks

This is the place to call the GetPromptCheckinOrUndoUnchangedFile method and SetPromptCheckinOrUndoUnchangedFile method.

If no method is called when this event is fired, the Check In operation will be cancelled.

See Also

  • GetPromptCheckinOrUndoUnchangedFile() method
  • SetPromptCheckinOrUndoUnchangedFile() method

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub sdkObject_PromptCheckinUnchangedFile()

    sdkObject.SetPromptCheckinOrUndoUnchangedFile Enum_CheckinUnchangedFile, True

End Sub


PromptLeaveOrReplaceWritableFile

PromptLeaveOrReplaceWritableFile Event

Description

Fired when you attempt to retrieve a file form server and a writable copy of this file already exits in the local disk.

Syntax

HRESULT ObjectName_PromptLeaveOrReplaceWritableFile()

Remarks

This is the place to call the GetPromptLeaveOrReplaceWritableFile method and SetPromptLeaveOrReplaceWritableFile method.

If no method is called when this event is fired, the Get or Check Out operation will be cancelled.

See Also

  • GetPromptLeaveOrReplaceWritableFile method
  • SetPromptLeaveOrReplaceWritableFile() method

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub sdkObject_PromptLeaveOrReplaceWriteableFile()

    sdkObject.SetPromptLeaveOrReplaceModifiedFile Enum_ReplaceModifiedFile, True

End Sub


PromptUndoCheckoutChangedFile

PromptUndoCheckoutChangedFile Event

Description

Fired when you attempt to undo checkout a file which has been changed.

Syntax

HRESULT ObjectName_PromptUndoCheckoutChangedFile()

Remarks

This is the place to call the GetPromptUndoCheckoutChangedFile method and SetPromptUndoCheckoutChangedFile method.

If no method is called when this event is fired, the Get or Check Out operation will be cancelled.

See Also

  • GetPromptUndoCheckoutChangedFile method
  • SetPromptUndoCheckoutChangedFile() method

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub sdkObject_PromptUndoCheckoutChangedFile()

    sdkObject.SetPromptUndoCheckoutChangedFile Enum_UndoCheckOutChangeFile, True

End Sub


OnPercentDone

OnPercentDone Event

Description

Fired when an operation begins.

Syntax

HRESULT ObjectName_OnPercentDone()

Remarks

This is the place to call GetPercentDone() method.

See Also

  • GetPercentDone() method

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub sdkObject_OnPercentDone()

    Dim PercentDone As Long
    PercentDone = sdkObject.GetPercentDone

End Sub


OnSendStatusMessage

OnSendStatusMessage Event

Description

Fired when the operation returns result information.

Syntax

HRESULT ObjectName_OnSendStatusMessage()

Remarks

This event will be fired after an operation is done.

This is the place to call GetOperationResultSend() method.

See Also

  • GetOperationResultSend() Method

Sample

VB Sample:

Dim WithEvents sdkObject As SAWHSDKLib.SAWHAppObject

Set sdkObject = New SAWHSDKLib.SAWHAppObject

Private Sub sdkObject_OnSendStatusMessage()

    Dim OperationResultSend As New SAWHOperationResultSend
    sdkObject.GetOperationResultSend OperationResultSend

End Sub


Enumerations

The following topics describe the enumerations for Dynamsoft SourceAnywhere Hosted COM SDK.

  • Enum_ActionType Enum
  • Enum_CheckinUnchangedFileHandling Enum
  • Enum_CompareFileBy Enum
  • Enum_ConnectionType Enum
  • Enum_EncryptType Enum
  • Enum_EOL Enum
  • Enum_FileType Enum
  • Enum_HistorySortBy Enum
  • Enum_ItemStatus Enum
  • Enum_LocalFileHandling Enum
  • Enum_ModifiedFileHandling Enum
  • Enum_ProxyType Enum
  • Enum_SetLocalFileTime Enum
  • Enum_UndoCheckOutChangedFileHandling Enum
  • Enum_UserRight Enum


EnumProxyType

Enum_PlanType Enum

Description

Indicates the plan type of your hosted account.

It is used with the following method.

Interface | Method
ISAWHAppObject | connectToServer

Constants
Name | Value | Description
enumFreePlan | 1 | Free plan account
enumStandardPlan | 2 | Standard plan account


EnumActionType

Enum_ClientType Enum

Description

Indicates the type of Dynamsoft SourceAnywhere Hosted Client.

It is used with the following properties.

Interface | Property
ISAWHLoginInfo | ClientType

Constants

Name | Value | Description
enumVCExplorer | 0 | Windows GUI Client
enumJavaGUIExplorer | 1 | Java GUI Client
enumVSIDE | 2 | Visual Studio IDE
enumMXPluginIDE | 3 | Macromedia Plug in
enumEclipsePlugin | 4 | Eclipse Plug in
enumWindowCMD | 5 | Windows Command Line
enumJavaCMD | 6 | Java Command Line
enumCOMSDK | 7 | COM SDK
enumJavaSDK | 8 | Java SDK
enumServerManager | 9 | Server Manager


EnumCheckinUnchangedFileHandling

Enum_CheckinUnchangedFileHandling Enum

Description

Indicates how to handle the unchanged file, checking in or undoing checkout.

It is used with the following methods.

Interface Method
ISAWHAppObject CheckInFiles()
CheckInProject()
SetPromptCheckinOrUndoUnchangedFile()

Constants

Name | Value | Description
Enum_AskUnchangedHandlingCanceled | 0 | Cancels the Check In operation.
Enum_AskCheckinUnchangedFile | 1 | Prompts whether you want to create a new version of file on server.
Enum_CheckinUnchangedFile | 2 | Checked in the file and updates the file to a new version.
Enum_UndoCheckinUnchangedFile | 3 | Undoes the checkout without updating file version number.


EnumCompareFileBy

Enum_CompareFileBy Enum

Description

Indicates how Dynamsoft SourceAnywhere Hosted determines if your local copy is up-to-date.

It is used with the following methods.

Interface Method
ISAWHAppObject AddFiles()
AddFolder()
GetOldVersionFile()
GetLatestFiles()
GetLatestProject()
GetLatestProjects()
CheckoutFiles()
CheckoutProject()
CheckInFiles()
CheckInProject()
IsFileSameAsOnServer()
UndoCheckOutFiles()
UndoCheckOutProject()

Constants
Name | Value | Description
Enum_CompareFileByTime | 0 | Compares the date/time flags.
Enum_CompareFileByChecksum | 1 | Compares by a checksum stored in Dynamsoft SourceAnywhere Hosted.


EnumConnectionType

Enum_ConnectionType Enum

Description

Indicates connection type.

It is used with the following method.

Interface | Method
ISAWHAppObject | SetConnectionType()

Constants

Name | Value | Description
Enum_LocalConnection | 0 | Uses local connection.
Enum_BroadBandConnection | 1 | Uses Broad Band Connection.
Enum_NarrowBandConnection | 2 | Uses Narrow Band Connection.


EnumProxyType

Enum_EncryptType Enum

Description

Indicates the encryption type of connection you established.

It is used with the following method.

Interface | Method
ISAWHAppObject | connectToServer

Constants
Name | Value | Description
Enum_Unencrypted | 0 | Unencrypted port
Enum_SSL | 2 | SSL encrypted port


EnumFileType

Enum_FileType Enum

Description

Indicates the type of the file on the server.

It is used with the following methods and properties.

Interface Method
ISAWHAppObject AddFiles()
AddFolder()
SetFileType()

Interface | Property
ISAWHAddFile | FileType

Constants

Name | Value | Description
Enum_Autodetect | 0 | Auto-detect file type
Enum_Binary | 1 | Binary file type
Enum_Text | 2 | Mergeable file type


EnumHistorySortBy

Enum_HistorySortBy Enum

Description

Indicates how to sort the history record.

It is used with the following property.

Interface | Property
ISAWHHistoryOrderBy | HistorySortBy

Constants

Name | Value | Description
Enum_HistorySortByName | 0 | Sorts item history by item name.
Enum_HistorySortByUser | 1 | Sorts item history by user name.
Enum_HistorySortByDate | 2 | Sorts item history by modified date of it.
Enum_HistorySortByVersion | 3 | Sorts item history by item version number.
Enum_HistorySortByAction | 4 | Sorts item history by action on it.


EnumItemStatus

Enum_ItemStatus Enum

Description

Indicates the status of the file or project.

It is used with the following properties.

Interface | Property
ISAWHFileStatusOut | FileStatus
ISAWHRecoverItem | ItemStatus
ISAWHFileCommonInfo | Item Status

Constants
Name | Value | Description
Enum_NomalFile | 0 | The file is in normal status.
Enum_PinnedFile | 1 | The file is being pinned.
Enum_SharedFile | 2 | The file is being shared.
Enum_SingleCheckoutFile | 3 | The file is being checked out by only one user.
Enum_SingleCheckoutSharedFile | 4 | The file is being checked out by only one user and shared.
Enum_MultiCheckoutFile | 5 | The file is being checked out by multiple users.
Enum_MultiCheckoutSharedFile | 6 | The file is being checked out by multiple users and shared.
Enum_ExclusiveCheckout | 7 | The file is being exclusively checked out.
Enum_ExclusiveCheckoutSharedFile | 8 | The file is being exclusively checked out and shared.
Enum_NormalProject | 0 | The project is in normal status.
Enum_CloakedProject | 2 | The Project is being cloaked.


EnumLocalFileHandling

Enum_LocalFileHandling Enum

Description

Indicates how to handle the local file copies when you perform the Check Out operation.

It is used with the following methods.

Interface Method
ISAWHAppObject UndoCheckoutFiles()
UndoCheckoutProject()

Constants

Name | Value | Description
Enum_LeaveLocalFile | 0 | Leaves the local file copy alone (does not retrieve the latest version from the repository).
Enum_ReplaceLocalFile | 1 | Replaces the modified local file copy with the file in Dynamsoft SourceAnywhere Hosted repository.
Enum_DeleteLocalFile | 2 | Deletes the local file copy.


EnumWritableFileHandling

Enum_ModifiedFileHandling Enum

Description

Indicates how to handle the writable local file if it is different from the file in the server.

It is used with the following methods.

Interface Method
ISAWHAppObject CheckOutFiles()
CheckOutProject()
GetOldVersionFile()
GetLatestFiles()
GetLatestProject()
GetLatestProjects()
SetPromptLeaveOrReplaceModifiedFile()

Constants
Name | Value | Description
Enum_AskModifiedHandlingCanceled | 0 | Cancels the Get or Checkout operation.
Enum_AskModifiedFile | 1 | Prompts you whether to leave or replace the local file.
Enum_ReplaceModifiedFile | 2 | Replace the local writable copy.
Enum_SkipModifiedFile | 3 | Leaves the local file alone
Enum_MergeModifiedFile | 4 | Attempts an automatic merge.


EnumProxyType

Enum_ProxyType Enum

Description

Indicates the proxy type of the server.

It is used with the following method.

Interface | Method
ISAWHAppObject | ConnectToServer()

Constants

Name | Value | Description
Enum_NOPROXY | 0 | No proxy is used.
Enum_SOCKS4 | 1 | SOCKS4 proxy is used.
Enum_SOCKS5 | 2 | SOCKS5 proxy is used
Enum_HTTP | 3 | HTTP proxy is used.


EnumSetLocalFileTime

Enum_SetLocalFileTime Enum

Description

Indicates how to set the date/time of the local file.

It is used with the following methods.

Interface Method
ISAWHAppObject AddFiles()
AddFolder()
CheckInFiles()
CheckInProject()
CheckOutFiles()
CheckOutProject()
GetOldVersionFile()
GetLatestFiles()
GetLatestProject()
GetLatestProjects()
IsFileSameAsOnServer()
UndoCheckoutFiles()
UndoCheckoutProject()

Constants

Name | Value | Description
Enum_SetLocalFileTimeCurrent | 0 | Sets the local file time to current time of the system.
Enum_SetLocalFileTimeModification | 1 | Sets the local file time to modification time of the file.
Enum_SetLocalFileTimeCheckIn | 2 | Sets the local file time to check-in time of the file.


EnumUndoCheckOutChangedFileHandling

Enum_UndoCheckOutChangedFileHandling Enum

Description

Indicates how to handle the local file when undoing checkout of a changed file and you choose to replace the local copy.

It is used with the following methods.

Interface Method
ISAWHAppObject UndoCheckoutFiles()
UndoCheckoutProject()

Constants

Name | Value | Description
Enum_CancelUndoCheckOutChangeFile | 0 | Cancels undoing check out of the file.
Enum_AskUndoCheckOutChangeFile | 1 | Prompts you whether to undo the checkout.
Enum_UndoCheckOutChangeFile | 2 | Undoes the checkout while replacing the local copy with the server version of the file.
Enum_NotUndoCheckOutChangeFile | 3 | Does not undo check out of the file.


EnumUserRight

Enum_UserRight Enum

Description

Indicates all levels of available access rights.

It is used with the following method.

Interface | Method
ISAWHRight | HasRightOf()

Constants

Name | Value | Description
Enum_ReadRight | 0x00000001 | Read right
Enum_CheckoutCheckinRight | 0x00000002 | Check in/Check out right
Enum_AddRight | 0x00000004 | Add right
Enum_DeleteRight | 0x00000008 | Delete/Recover right
Enum_ShareRight | 0x00010000 | Share right
Enum_BranchRight | 0x00020001 | Branch right
Enum_MoveRight | 0x00040001 | Move right
Enum_RenameRight | 0x00080001 | Rename right
Enum_PurgeRight | 0x00100001 | Purge right
Enum_PinRight | 0x00200001 | Pin/Unpin right
Enum_LabelRight | 0x00400001 | Label right
Enum_PropertyChangeRight | 0x01000001 | Property Change right


Error List

The followings are the errors defined in Dynamsoft SourceAnywhere Hosted SDK:

Value | Description
11001 | Socket closed.
11002 | Socket error.
11003 | Socket cancelled.
11004 | Socket out of memory.
11005 | Unspecified socket error.
11101 | Unspecified file transfer error.
11102 | Out of disk when transferring files.
11103 | Read file error.
11301 | Socket error.
11302 | Socket operation cancelled.
11303 | Failed to connect to proxy server.
11304 | Proxy authentication error.
11305 | Incorrect remote address.
11306 | The proxy server response error.
11307 | The proxy server needs authentication.
11308 | Unknown authorized mode.
11309 | Unknown proxy type.
11310 | Unspecified proxy error.
12001 | Magic word error.
12002 | Version is not compatible.
12003 | Cannot find CA.
12004 | Unknown encryption type.
12005 | Received error file length.
12006 | System busy.
12007 | System cancelled.
12008 | System error.
12009 | Product type is not compatible.
13001 | Out of memory on server.
13002 | Wrong configuration on server.
13003 | System error on server.
13004 | User is not configured on server.
13005 | User is locked on server.
13006 | License on server has expired.
13010 | Unspecified server error.
13011 | Get file checksum error on server.
13012 | Read configuration file error on server.
13013 | COM error on server.
19000 | Transfer file error on low level.
19001 | Unspecified low-level error.
19002 | COM error on low level.
19003 | Invalid deploy path.
30002 | File or project is not found.
30003 | Local directory is not found.
30004 | Local file is not found.
30005 | Local path is too long.
30006 | Failed to create Project.
30007 | Failed to create local folder.
30008 | Failed to merge file.
30009 | Failed to get local file time.
30010 | Failed to get checksum.
30011 | File or project already exists.
30012 | Local directory already exists.
30013 | Root project cannot be renamed.
30014 | Root project cannot be moved.
30015 | Temp directory is not available.
30016 | Cancelled.
30017 | The specified folder cannot be added.
30018 | The file type has been excluded by server.
30019 | Check in the file which has not been checked out by you.
30020 | Check out the file which has been already checked out.
30021 | Failed to get local file size.
30022 | Undo check out a pinned file.
30023 | Check out a pinned file.
30024 | Check in a pinned file.
30025 | File name is invalid.
30026 | Project name is invalid.
30027 | Check in an unchecked-out file.
30028 | A directory with the same name as the checked-out file already exists in the working folder.
30029 | Undo check out an unchecked-out file.
30030 | Check in a nonexistent file, but a directory with the same name exists in the working folder.


Java SDK

Dynamsoft SourceAnywhere Hosted Java Software Development Kit (SDK) enables you to integrate Dynamsoft SourceAnywhere Hosted functionality with your Java applications.

For information on how to use Dynamsoft SourceAnywhere Hosted Java SDK, please refer to the document that comes with Dynamsoft SourceAnywhere Hosted Java SDK.


ISAWSDeleteProject Interface

ISAWHDeleteProjectSet Interface

ISAWHDeleteProjectSet is the interface for storing the name set of projects to be deleted.

The ISAWHDeleteProjectSet interface exposes the following method.

  • Add

ISAWHDeleteProjectSet is used for the following method.

Interface | Method
ISAWHAppObject | DeleteProject


ActionDateTime

ISAWHHistory::ActionDateTime

Description

Returns the date/time of the action.

Syntax

DATE ObjectName.ActionDateTime

See Also

  • ISAWHHistory Interface


HistoryIdLow

ISAWHHistory::HistoryId Low

Description

Returns the low-order 32 bits of the history record ID.

Syntax

long ObjectName.HistoryId Low

See Also

  • ISAWHHistory Interface


ItemName

ISAWHLoginInfo::LoginResult

Description

Specifies if the login was successful or failed.

Syntax

string ObjectName.LoginResult

See Also

  • ISAWHLoginInfo Interface


ISAWRecoverItemSet Interface

ISAWHRecoverItemSet Interface

ISAWHRecoverItemSet is the interface for managing ISAWHRecoverItem objects.

The ISAWHRecoverItemSet interface exposes the following methods.

  • GetCount
  • Get
  • Add

ISAWHRecoverItemSet interface is used for the following method.

Interface | Method
ISAWHAppObject | RecoverItems